summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-09-06 23:04:47 -0700
committerAndy Weidenbaum2017-09-06 23:04:47 -0700
commit6a5191a85a270b229533bb3990b00a0c00f9dc96 (patch)
treed2db0230df92c9228c5c73ef4ad94f1a8621809b
downloadaur-6a5191a85a270b229533bb3990b00a0c00f9dc96.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..921b50682892
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Sep 7 06:04:16 UTC 2017
+pkgbase = perl6-io-path-childsecure
+ pkgdesc = Secure version of IO::Path.child
+ pkgver = 1.001009
+ pkgrel = 1
+ url = https://github.com/zoffixznet/perl6-IO-Path-ChildSecure
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ checkdepends = perl6-test-meta
+ makedepends = git
+ depends = perl6
+ source = perl6-io-path-childsecure-1.001009::git+https://github.com/zoffixznet/perl6-IO-Path-ChildSecure
+ sha256sums = SKIP
+
+pkgname = perl6-io-path-childsecure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..286b9af35a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-io-path-childsecure
+pkgver=1.001009
+pkgrel=1
+pkgdesc="Secure version of IO::Path.child"
+arch=('any')
+depends=('perl6')
+checkdepends=('perl' 'perl6-test-meta')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/zoffixznet/perl6-IO-Path-ChildSecure"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/zoffixznet/perl6-IO-Path-ChildSecure)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ export RAKUDO_LOG_PRECOMP=1
+ export RAKUDO_RERESOLVE_DEPENDENCIES=0
+ perl6-install-dist \
+ --to="$pkgdir/usr/share/perl6/vendor" \
+ --for=vendor \
+ --from=.
+}