summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-09-06 23:04:47 -0700
committerAndy Weidenbaum2017-09-06 23:04:47 -0700
commit1ae8e1ba4ee9eab489c58060724debbfd92d76b5 (patch)
tree6f8b8714ee40a50cafc8336149a66ec29bafaa4e
downloadaur-1ae8e1ba4ee9eab489c58060724debbfd92d76b5.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ded03771a865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Sep 7 06:04:16 UTC 2017
+pkgbase = perl6-io-socket-async-ssl
+ pkgdesc = Provides an API like IO::Socket::Async, but with SSL support
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/jnthn/p6-io-socket-async-ssl
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = git
+ depends = perl6
+ depends = perl6-openssl
+ source = perl6-io-socket-async-ssl-0.3::git+https://github.com/jnthn/p6-io-socket-async-ssl
+ sha256sums = SKIP
+
+pkgname = perl6-io-socket-async-ssl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78ec8b84a1e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-io-socket-async-ssl
+pkgver=0.3
+pkgrel=1
+pkgdesc="Provides an API like IO::Socket::Async, but with SSL support"
+arch=('any')
+depends=('perl6' 'perl6-openssl')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/jnthn/p6-io-socket-async-ssl"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/jnthn/p6-io-socket-async-ssl)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cp -dpr --no-preserve=ownership examples "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ export RAKUDO_LOG_PRECOMP=1
+ export RAKUDO_RERESOLVE_DEPENDENCIES=0
+ perl6-install-dist \
+ --to="$pkgdir/usr/share/perl6/vendor" \
+ --for=vendor \
+ --from=.
+}