summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-11-17 15:50:43 -0800
committerAndy Weidenbaum2015-11-17 15:50:43 -0800
commitf8a7c021018539027e57a4d6ee923ed899ecf322 (patch)
tree6a2dd34889b67b8501492b66712843d333d904ce
downloadaur-f8a7c021018539027e57a4d6ee923ed899ecf322.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23250759da7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl6-json-class
+ pkgdesc = Role to provide simple serialisation/deserialisation of objects to/from JSON
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/jonathanstowe/JSON-Class
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = git
+ depends = rakudo
+ depends = perl6-json-marshall
+ depends = perl6-json-unmarshall
+ source = perl6-json-class-0.0.2::git+https://github.com/jonathanstowe/JSON-Class
+ sha256sums = SKIP
+
+pkgname = perl6-json-class
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a314e9182c4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-json-class
+_p6name=JSON-Class
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Role to provide simple serialisation/deserialisation of objects to/from JSON"
+arch=('any')
+depends=('rakudo' 'perl6-json-marshall' 'perl6-json-unmarshall')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/jonathanstowe/JSON-Class"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/jonathanstowe/JSON-Class)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}