summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-12-31 09:42:10 -0800
committerAndy Weidenbaum2015-12-31 09:42:10 -0800
commit2994c703c38bbebb5921c791a80e321a182e4269 (patch)
treea379dc186cb32b8adfbdedf5118a0d7a71dd912f
parent763e20989a759edbd5117ff5a9e0061bde2bb783 (diff)
downloadaur-2994c703c38bbebb5921c791a80e321a182e4269.tar.gz
use alacryd pkging
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e4b2e42eb2a..1d4c51cfa71f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 01:18:07 UTC 2015
+# Thu Dec 31 17:40:48 UTC 2015
pkgbase = perl6-json-tiny
pkgdesc = A tiny JSON parser and emitter for Perl 6 on Rakudo
pkgver = 0.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/moritz/json
arch = any
groups = perl6
license = PerlArtistic
checkdepends = perl
+ makedepends = alacryd
makedepends = git
depends = rakudo
source = perl6-json-tiny-0.0.1::git+https://github.com/moritz/json
diff --git a/PKGBUILD b/PKGBUILD
index bccb221e2aba..46977a1a8a36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=perl6-json-tiny
pkgver=0.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="A tiny JSON parser and emitter for Perl 6 on Rakudo"
arch=('any')
depends=('rakudo')
checkdepends=('perl')
-makedepends=('git')
+makedepends=('alacryd' 'git')
groups=('perl6')
url="https://github.com/moritz/json"
license=('PerlArtistic')
@@ -24,8 +24,25 @@ check() {
package() {
cd "$srcdir/$pkgname-$pkgver"
+ msg2 'Installing documentation...'
+ install -Dm 644 README -t "$pkgdir/usr/share/doc/$pkgname"
+
msg2 'Installing...'
- mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
- find lib -mindepth 1 -maxdepth 1 -exec \
- cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qg perl6 \
+ | awk '{print $2}' \
+ | xargs pacman -Ql \
+ | awk '{print $2}' \
+ | grep precomp))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+ find "$pkgdir" -type f -print0 | xargs -0 sed -i "s,$pkgdir,,g"
}