summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-11-17 00:09:51 -0800
committerAndy Weidenbaum2015-11-17 00:09:51 -0800
commit2d1bf2e6a4d5f41c76c23c75744a391271798a24 (patch)
tree001b1bf388bd1cdb4aedeab6f171f01fe3629c3e
downloadaur-2d1bf2e6a4d5f41c76c23c75744a391271798a24.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..886fbf1a0d39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl6-json-tiny
+ pkgdesc = A tiny JSON parser and emitter for Perl 6 on Rakudo
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/moritz/json
+ arch = any
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = git
+ depends = rakudo
+ source = perl6-json-tiny-0.0.1::git+https://github.com/moritz/json
+ sha256sums = SKIP
+
+pkgname = perl6-json-tiny
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec5cd713542
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-json-tiny
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A tiny JSON parser and emitter for Perl 6 on Rakudo"
+arch=('any')
+depends=('rakudo')
+checkdepends=('perl')
+makedepends=('git')
+url="https://github.com/moritz/json"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/moritz/json)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}