summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-07 16:09:47 -0800
committerAndy Weidenbaum2016-01-07 16:09:47 -0800
commitd473537075c88094f0b8e9374299fbbd5b0a2274 (patch)
treeffbfeb1efdaf6c95d10f9d18fe7760acde8ff8b3
downloadaur-d473537075c88094f0b8e9374299fbbd5b0a2274.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..080edc112e47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 00:07:36 UTC 2016
+pkgbase = perl6-slang-tuxic
+ pkgdesc = Allows you to put whitespace between the name of a subroutine and the opening parenthesis
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/FROGGS/p6-Slang-Tuxic
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = perl6
+ source = perl6-slang-tuxic-0.0.1::git+https://github.com/FROGGS/p6-Slang-Tuxic
+ sha256sums = SKIP
+
+pkgname = perl6-slang-tuxic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1a888eff881
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-slang-tuxic
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Allows you to put whitespace between the name of a subroutine and the opening parenthesis"
+arch=('any')
+depends=('perl6')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/FROGGS/p6-Slang-Tuxic"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/FROGGS/p6-Slang-Tuxic)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qg perl6 \
+ | awk '{print $2}' \
+ | xargs pacman -Ql \
+ | awk '{print $2}' \
+ | grep precomp))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+}