summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:06:19 +0200
committerM0Rf302015-06-17 16:06:19 +0200
commitd36e0558ff2be2b69b2dd3fa410cb0b355ef6577 (patch)
treec337ad07e8f0c6033f77f214ad104cb033dc8e3c
downloadaur-d36e0558ff2be2b69b2dd3fa410cb0b355ef6577.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--perp.install16
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62b5db7d8b5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perp
+ pkgdesc = Perp, aka the perpetrator, a persistent process supervisor.
+ pkgver = 2.07
+ pkgrel = 1
+ url = http://b0llix.net/perp/
+ install = perp.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://b0llix.net/perp/distfiles/perp-2.07.tar.gz
+ md5sums = a2acc7425d556d9635a25addcee9edb5
+
+pkgname = perp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acc3472552f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: M0Rf30
+
+pkgname=perp
+pkgver=2.07
+pkgrel=1
+arch=(i686 x86_64)
+pkgdesc="Perp, aka the perpetrator, a persistent process supervisor."
+url="http://b0llix.net/perp/"
+license=('GPL')
+source=(http://b0llix.net/perp/distfiles/$pkgname-$pkgver.tar.gz)
+install=perp.install
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
+
+md5sums=('a2acc7425d556d9635a25addcee9edb5')
diff --git a/perp.install b/perp.install
new file mode 100644
index 000000000000..260dbc066c14
--- /dev/null
+++ b/perp.install
@@ -0,0 +1,16 @@
+post_install() {
+echo " >> to activate perp, run the commands "
+echo " >> # perp-setup /etc/perp"
+echo " >> # kill -HUP 1"
+echo " >> become familiar with perp's configuration and operation. skim the manual pages for perp_intro(8), perpd(8), and perpetrate(5)."
+}
+
+post_upgrade() {
+echo " >> If upgrading a previous perp installation, follow all the steps above. The perp-setup(8) utility script will not disturb any previous
+configuration it finds in any of /etc/inittab, /etc/rc.local, or /etc/perp/.boot."
+echo " >> As a special case, if upgrading from perp-0.00 to a later release in"
+echo " >> the perp-2.* series, it will be necessary to remove a couple of old"
+echo " >> files from the earlier release manually. These are:"
+echo " >> /usr/sbin/perpetrate"
+echo " >> /usr/share/man/man8/perpetrate.8"
+}