summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-12-11 16:23:02 +0330
committerMohammadreza Abdollahzadeh2017-12-11 16:23:02 +0330
commita79a0ac8df116a82f8fab8210de5596104c65787 (patch)
tree49ec7339289d23779b7d82cf49e5716084a9b3fb
parentbbdcf18cf6a845d947d3d79ae742d0340d349165 (diff)
downloadaur-a79a0ac8df116a82f8fab8210de5596104c65787.tar.gz
update to v3.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99db50900250..3738642e84aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
# Generated by mksrcinfo v8
-# Mon Apr 17 18:39:05 UTC 2017
+# Mon Dec 11 12:52:32 UTC 2017
pkgbase = persepolis
pkgdesc = A graphical front-end for aria2 download manager with lots of features.
- pkgver = 2.4.2
+ pkgver = 3.0.0
pkgrel = 1
url = https://persepolisdm.github.io/
arch = any
license = GPL3
+ makedepends = python-setuptools
depends = aria2
depends = libnotify
depends = python
+ depends = python-psutil
depends = python-pyqt5
depends = python-requests
depends = python-setproctitle
depends = qt5-svg
+ depends = sound-theme-freedesktop
optdepends = firefox-flashgot: for integrating with firefox.
- provides = persepolis
- conflicts = persepolis
- source = persepolis-2.4.2.tar.gz::https://github.com/persepolisdm/persepolis/archive/2.4.2.tar.gz
- sha256sums = d4e9aa12946d70bb246dfef0813ea12feb82424ca873cc81a37e6ee53010773f
+ source = persepolis-3.0.0.tar.gz::https://github.com/persepolisdm/persepolis/archive/3.0.0.tar.gz
+ sha256sums = 6d4a94de61662a61937dca8d0a89b7c515b09d30a0c7c821846ff97066d29ec8
pkgname = persepolis
diff --git a/PKGBUILD b/PKGBUILD
index 8aa9544ac703..04030dc36097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
+# $Id$
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname='persepolis'
-pkgver=2.4.2
+pkgver=3.0.0
pkgrel=1
pkgdesc="A graphical front-end for aria2 download manager with lots of features."
arch=('any')
url="https://persepolisdm.github.io/"
license=('GPL3')
-depends=('aria2' 'libnotify' 'python' 'python-pyqt5' 'python-requests' 'python-setproctitle' 'qt5-svg')
+depends=('aria2' 'libnotify' 'python' 'python-psutil' 'python-pyqt5' 'python-requests' 'python-setproctitle' 'qt5-svg' 'sound-theme-freedesktop')
+makedepends=('python-setuptools')
optdepends=('firefox-flashgot: for integrating with firefox.')
-provides=("${pkgname}")
-conflicts=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/persepolisdm/persepolis/archive/${pkgver}.tar.gz")
-sha256sums=('d4e9aa12946d70bb246dfef0813ea12feb82424ca873cc81a37e6ee53010773f')
+sha256sums=('6d4a94de61662a61937dca8d0a89b7c515b09d30a0c7c821846ff97066d29ec8')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
gzip -k -9 ./man/persepolis.1
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -d ${pkgdir}/usr/share/persepolis
- cp -a ./files/* ${pkgdir}/usr/share/persepolis
- install -Dm755 ./persepolis ${pkgdir}/usr/bin/persepolis
- install -Dm644 ./persepolis.desktop ${pkgdir}/usr/share/applications/persepolis.desktop
- install -Dm644 ./man/persepolis.1.gz ${pkgdir}/usr/share/man/man1/persepolis.1.gz
- install -Dm644 ./files/icon.svg ${pkgdir}/usr/share/pixmaps/persepolis.svg
- install -Dm644 ./LICENSE ${pkgdir}/usr/share/licenses/persepolis/LICENSE
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
}
+# vim:set ts=2 sw=2 et: