summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2016-10-14 17:23:36 +0330
committerMohammadreza Abdollahzadeh2016-10-14 17:23:36 +0330
commitcb20c7d84344c34eae7b6047697192089788649c (patch)
tree3de49115077db443001739ccf3a18e6aaf581492
downloadaur-cb20c7d84344c34eae7b6047697192089788649c.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD25
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be218226537e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Oct 14 13:53:12 UTC 2016
+pkgbase = persepolis
+ pkgdesc = A graphical front-end for aria2 download manager with lots of features.
+ pkgver = 2.2.2_unstable
+ pkgrel = 1
+ url = https://persepolisdm.github.io/
+ arch = any
+ license = GPL3
+ depends = aria2
+ depends = vorbis-tools
+ depends = libnotify
+ depends = python
+ depends = python-pyqt5
+ depends = qt5-svg
+ optdepends = firefox-flashgot: for integrating with firefox.
+ provides = persepolis
+ provides = persepolis
+ conflicts = persepolis
+ conflicts = persepolis
+ source = persepolis.tar.gz::https://github.com/persepolisdm/persepolis/archive/2.2.2_unstable.tar.gz
+ md5sums = 048ce74b8f8e4d0ef00ebe909f9f55cc
+
+pkgname = persepolis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35496b77ca75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname='persepolis'
+pkgver=2.2.2_unstable
+pkgrel=1
+pkgdesc="A graphical front-end for aria2 download manager with lots of features."
+arch=('any')
+url="https://persepolisdm.github.io/"
+license=('GPL3')
+depends=('aria2' 'vorbis-tools' 'libnotify' 'python' 'python-pyqt5' 'qt5-svg')
+optdepends=('firefox-flashgot: for integrating with firefox.')
+provides=("${pkgname}" "persepolis")
+conflicts=("${pkgname}" "persepolis")
+source=("${pkgname}.tar.gz::https://github.com/persepolisdm/persepolis/archive/${pkgver}.tar.gz")
+md5sums=('048ce74b8f8e4d0ef00ebe909f9f55cc')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d ${pkgdir}/usr/{bin,share/{persepolis,pixmaps,applications,licenses/persepolis}}
+ cp -a ./files/* ${pkgdir}/usr/share/persepolis
+ install -Dm755 ./persepolis ${pkgdir}/usr/bin/persepolis
+ install -Dm644 ./Persepolis\ Download\ Manager.desktop ${pkgdir}/usr/share/applications/persepolis.desktop
+ cp ./files/icon.svg ${pkgdir}/usr/share/pixmaps/persepolis.svg
+ cp ./LICENSE ${pkgdir}/usr/share/licenses/persepolis/
+}