summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Cabanilla2015-08-20 22:17:43 -0400
committerCarlo Cabanilla2015-08-20 22:17:43 -0400
commit8a9814f76a218ba7cee3ce968433dea29e78b7e0 (patch)
tree108068bd9496a6c410c10f5f3e5e542559657f92
parentcd3ecf560b202f3e50e03b70d7fffed8710c17fe (diff)
downloadaur-8a9814f76a218ba7cee3ce968433dea29e78b7e0.tar.gz
upgrade, fix connection issues
for some reason the rpm version doesnt work anymore, but the deb does
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
-rw-r--r--client.conf5
-rw-r--r--pgateway.service10
5 files changed, 57 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fee7d401db02..b3d0b74ec3a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,27 @@
pkgbase = pertino
pkgdesc = Cloud-based VPN client
- pkgver = 466.4505
+ pkgver = 470.4537
pkgrel = 1
url = http://pertino.com/
install = pertino.install
arch = i686
arch = x86_64
license = proprietary
- makedepends = rpmextract
makedepends = sed
depends = dhclient
- noextract = pertino-466.4505-1..rpm
- source = http://download.pertino.com/clients/linux/466-4505/pertino-466.4505-1..rpm
- sha1sums = 9984674aacd0d9170b8ba838f6d7df7774244711
+ backup = usr/share/pgateway/conf/client.conf
+ source_i686 = client.conf
+ source_i686 = pgateway.service
+ source_i686 = http://download.pertino.com/clients/linux/470-4537/pertino_470.4537-1_i386.deb
+ sha1sums_i686 = 16c08a94d0e72d610fef71ed6ed0839db56d6484
+ sha1sums_i686 = 1ed8d0eef425ca9ee605c3e9510010065e71b222
+ sha1sums_i686 = b70d22aaa843c5b99661778dfb789480d601af99
+ source_x86_64 = client.conf
+ source_x86_64 = pgateway.service
+ source_x86_64 = http://download.pertino.com/clients/linux/470-4537/pertino_470.4537-1_amd64.deb
+ sha1sums_x86_64 = 16c08a94d0e72d610fef71ed6ed0839db56d6484
+ sha1sums_x86_64 = 1ed8d0eef425ca9ee605c3e9510010065e71b222
+ sha1sums_x86_64 = 891650db47a3943234d3d31d7b6be6aef729edb6
pkgname = pertino
diff --git a/.gitignore b/.gitignore
index b80a5c5f3c85..5048457fe3d3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pertino-*.gz
-pertino-*.rpm
pertino-*.xz
+pertino*.deb
pkg
+
diff --git a/PKGBUILD b/PKGBUILD
index 8c5a9d159be4..61989416a99c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
# Maintainer: Carlo Cabanilla <carlo.cabanilla@gmail.com>
pkgname=pertino
-pkgver=466.4505
+pkgver=470.4537
pkgrel=1
pkgdesc="Cloud-based VPN client"
arch=(i686 x86_64)
url="http://pertino.com/"
license=('proprietary')
depends=('dhclient')
-makedepends=('rpmextract' 'sed')
-source=("http://download.pertino.com/clients/linux/$(echo $pkgver | tr . -)/$pkgname-$pkgver-1.$CARCH.rpm")
-noextract=($(basename "${source[0]}"))
-sha1sums=('9984674aacd0d9170b8ba838f6d7df7774244711')
+makedepends=('sed')
+_srcfileprefix="${pkgname}_${pkgver}-1_"
+source_i686=("client.conf" "pgateway.service" "http://download.pertino.com/clients/linux/$(echo $pkgver | tr . -)/${_srcfileprefix}i386.deb")
+source_x86_64=("client.conf" "pgateway.service" "http://download.pertino.com/clients/linux/$(echo $pkgver | tr . -)/${_srcfileprefix}amd64.deb")
+noextract=("${source[@]%%::*}")
+sha1sums_i686=(16c08a94d0e72d610fef71ed6ed0839db56d6484 1ed8d0eef425ca9ee605c3e9510010065e71b222 b70d22aaa843c5b99661778dfb789480d601af99)
+sha1sums_x86_64=(16c08a94d0e72d610fef71ed6ed0839db56d6484 1ed8d0eef425ca9ee605c3e9510010065e71b222 891650db47a3943234d3d31d7b6be6aef729edb6)
install=${pkgname}.install
+backup=(usr/share/pgateway/conf/client.conf)
package() {
- srcfile="${noextract[0]}"
+ # extract source deb file
+ if [ "x$CARCH" = "xx86_64" ]
+ then
+ srcfile=${_srcfileprefix}amd64.deb
+ else
+ srcfile=${_srcfileprefix}i386.deb
+ fi
mv "$srcfile" "$pkgdir"
cd "$pkgdir"
- rpmextract.sh "$pkgdir/$srcfile"
- rm "$pkgdir/$srcfile"
-
- # Put the systemd unit in the proper place and patch the executable
- mkdir -p "$pkgdir/usr/lib/systemd/system/"
- sed -e 's#/opt/pertino/pgateway/pGateway#/usr/bin/pGateway#' \
- "$pkgdir/opt/pertino/pgateway/init/pgateway.service" \
- > "$pkgdir/usr/lib/systemd/system/pgateway.service"
+ ar -xf "$pkgdir/$srcfile"
+ tar -xzf data.tar.gz
+ rm "$srcfile" "control.tar.gz" "data.tar.gz" "debian-binary"
# Remove the other init scripts
rm -rf "$pkgdir/opt/pertino/pgateway/init"
@@ -35,6 +40,13 @@ package() {
rmdir "$pkgdir/opt/pertino/"
rmdir "$pkgdir/opt"
+ # base config
+ cp "$srcdir/client.conf" "$pkgdir/usr/share/pgateway/conf/client.conf"
+
+ # systemd unit
+ mkdir -p "$pkgdir/usr/lib/systemd/system/"
+ cp "$srcdir/pgateway.service" "$pkgdir/usr/lib/systemd/system/pgateway.service"
+
# Symlink the executables
mkdir -p "$pkgdir/usr/bin"
ln -s "/usr/share/pgateway/pGateway" "$pkgdir/usr/bin/pGateway"
diff --git a/client.conf b/client.conf
new file mode 100644
index 000000000000..1cf985c39120
--- /dev/null
+++ b/client.conf
@@ -0,0 +1,5 @@
+[root]
+Environment = PROD
+MasterController = mc470.pertino.com
+catEnabled = true
+
diff --git a/pgateway.service b/pgateway.service
new file mode 100644
index 000000000000..d85e8a76f8f5
--- /dev/null
+++ b/pgateway.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Pertino Client that provides access to the Pertino Network.
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/pGateway
+Restart=on-abort
+
+[Install]
+WantedBy=basic.target