summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack O'Connor2015-06-08 15:26:44 -0400
committerJack O'Connor2015-06-08 15:26:44 -0400
commit5b53ade06cf8326ea23660f7f40992f38e181ff9 (patch)
tree2fb33abd0d37d0322e7e2d6d761d1691bf0ef063
downloadaur-5b53ade06cf8326ea23660f7f40992f38e181ff9.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a44f0574f05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = peru-git
+ pkgdesc = A tool for fetching code
+ pkgver = 458.b22107e
+ pkgrel = 1
+ url = https://github.com/buildinspace/peru
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-yaml
+ depends = python-docopt
+ depends = git
+ optdepends = mercurial: fetching from hg repos
+ optdepends = subversion: fetching from svn repos
+ source = git://github.com/buildinspace/peru
+ md5sums = SKIP
+
+pkgname = peru-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95bc67a99d71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jack O'Connor <oconnor663@gmail.com>
+
+pkgname=peru-git
+pkgdesc='A tool for fetching code'
+url='https://github.com/buildinspace/peru'
+license=('MIT')
+pkgver=458.b22107e
+pkgver() {
+ cd "$srcdir/peru"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+pkgrel=1
+arch=('any')
+# Asyncio and pathlib are standard in Python 3.4, so they're not in the
+# dependencies list.
+depends=(python python-yaml python-docopt git)
+makedepends=(python-setuptools)
+optdepends=(
+ 'mercurial: fetching from hg repos'
+ 'subversion: fetching from svn repos'
+)
+source=('git://github.com/buildinspace/peru')
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/peru"
+ python3 setup.py install --root="$pkgdir"
+}