summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-06-23 05:15:45 +0530
committerKeshav Amburay2013-06-23 05:15:45 +0530
commitbfb8bbc02adb84d67728eb639064a6116a28b642 (patch)
tree7b8206ef2e22d36965cce40d854bf60102544747
parenta0c9076e25655e26666227f1368b719f436d537c (diff)
downloadaur-bfb8bbc02adb84d67728eb639064a6116a28b642.tar.gz
Fix pkgver
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 407e9dfee6bf..7fe445baa59f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = pesign-git
pkgdesc = Tools for manipulating signed PE-COFF binaries - GIT Version
- pkgver = 0.106.1.g7b60469.7b60469
+ pkgver = 0.106.1.g7b60469
pkgrel = 1
url = https://github.com/vathpela/pesign
arch = x86_64
- arch = i686
license = GPL2
makedepends = git
depends = popt
diff --git a/.gitignore b/.gitignore
index f1307f4c59eb..3ccde5a9a794 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ pkg/
*.tar.xz
*.tar.gz
*.log*
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index 0b9f67461e8b..9e0916f13b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ _gitbranch="master"
_pkgname="pesign"
pkgname="${_pkgname}-git"
-pkgver=0.106.1.g7b60469.7b60469
+pkgver=0.106.1.g7b60469
pkgrel=1
pkgdesc="Tools for manipulating signed PE-COFF binaries - GIT Version"
url="https://github.com/vathpela/pesign"
-arch=('x86_64' 'i686')
+arch=('x86_64')
license=('GPL2')
makedepends=('git')
depends=('popt' 'nss')
@@ -26,7 +26,7 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}/"
- echo "$(git describe --tags).$(git describe --always)" | sed 's|-|.|g'
+ echo "$(git describe --tags)" | sed 's|-|.|g'
}
build() {
@@ -58,4 +58,6 @@ package() {
chmod 0644 "${pkgdir}/usr/lib/libdpe.a"
+ rm -rf "${pkgdir}/etc/rpm/"
+
}