aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRapiz2019-09-19 12:36:11 +0800
committerRapiz2019-09-19 12:37:22 +0800
commitd311ef58892b055c1f49fe1d7f7f2f0ac667123b (patch)
tree3dc3d411eb339a89f67dcab9bc02088cfeccc450
downloadaur-d311ef58892b055c1f49fe1d7f7f2f0ac667123b.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD50
-rwxr-xr-xPetal.desktop9
-rw-r--r--petal.sh2
-rw-r--r--petal.svg54
7 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0a3039a9746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = petal-bin
+ pkgdesc = A Douban.FM Client With Extra
+ pkgver = 2.20.0
+ pkgrel = 1
+ url = https://ilime.github.io/Petal/
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = nss
+ depends = libxss
+ source = https://github.com/ilime/Petal/releases/download/v2.20.0/Petal-2.20.0.tar.gz
+ source = https://raw.githubusercontent.com/ilime/Petal/dev/LICENSE
+ source = petal.svg
+ source = Petal.desktop
+ source = petal.sh
+ md5sums = 41c8c259ff57c36749f6615105c33937
+ md5sums = cebd0dda9b913e6254f5e09a257955bb
+ md5sums = a4f3cb91573bbc3fce9466350ddfb4d2
+ md5sums = e946f427355b1a85454b74e7ca918072
+ md5sums = 5c3aace4646132860b8084cbbb55ad55
+
+pkgname = petal-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d4715b5982f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.gz
+*.xz
+update.sh
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c1a7ca5d63ed
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 ilime
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e38642b689c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer:
+# g1eny0ung <g1eny0ung@gmail.com>
+# rapiz <contact@rapiz.me>
+# lxs137 <lxs137@hotmail.com>
+pkgname=petal-bin
+pkgver=2.20.0
+pkgrel=1
+epoch=
+pkgdesc="A Douban.FM Client With Extra"
+arch=('x86_64')
+url="https://ilime.github.io/Petal/"
+license=('MIT')
+groups=()
+depends=('gtk3' 'nss' 'libxss')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/ilime/Petal/releases/download/v$pkgver/Petal-$pkgver.tar.gz"
+ 'https://raw.githubusercontent.com/ilime/Petal/dev/LICENSE'
+ 'petal.svg'
+ 'Petal.desktop'
+ 'petal.sh'
+)
+noextract=()
+validpgpkeys=()
+md5sums=('41c8c259ff57c36749f6615105c33937'
+ 'cebd0dda9b913e6254f5e09a257955bb'
+ 'a4f3cb91573bbc3fce9466350ddfb4d2'
+ 'e946f427355b1a85454b74e7ca918072'
+ '5c3aace4646132860b8084cbbb55ad55')
+
+package() {
+ mkdir -p "$pkgdir/usr/lib"
+ cp -r "$srcdir/Petal-$pkgver" "$pkgdir/usr/lib/petal"
+
+ install -Dm755 "$srcdir/petal.sh" "$pkgdir/usr/bin/petal"
+ install -Dm644 "$srcdir/Petal.desktop" -t "$pkgdir/usr/share/applications/"
+
+ ICON="$srcdir/petal.svg"
+ install -Dm644 "$ICON" "$pkgdir/usr/share/icons/hicolor/scalable/apps/petal.svg"
+
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/petal/LICENSE"
+}
diff --git a/Petal.desktop b/Petal.desktop
new file mode 100755
index 000000000000..409d45b39216
--- /dev/null
+++ b/Petal.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Petal
+Comment=Douban FM Player With Extra
+Terminal=false
+Categories=Audio
+Exec=petal
+Type=Application
+Icon=petal
+Version=2.20.0
diff --git a/petal.sh b/petal.sh
new file mode 100644
index 000000000000..57d4b734d382
--- /dev/null
+++ b/petal.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+exec /usr/lib/petal/petal
diff --git a/petal.svg b/petal.svg
new file mode 100644
index 000000000000..05a76a8a47fc
--- /dev/null
+++ b/petal.svg
@@ -0,0 +1,54 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ version="1.1"
+ width="24"
+ height="24"
+ viewBox="0 0 24 24"
+ id="svg4"
+ sodipodi:docname="petal.svg"
+ inkscape:version="0.92.4 5da689c313, 2019-01-14">
+ <metadata
+ id="metadata10">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <defs
+ id="defs8" />
+ <sodipodi:namedview
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="625"
+ inkscape:window-height="1030"
+ id="namedview6"
+ showgrid="false"
+ inkscape:zoom="9.8333333"
+ inkscape:cx="2.0847458"
+ inkscape:cy="12"
+ inkscape:window-x="2185"
+ inkscape:window-y="40"
+ inkscape:window-maximized="0"
+ inkscape:current-layer="svg4" />
+ <path
+ d="M18.5,12A3.5,3.5 0 0,0 22,8.5A6.5,6.5 0 0,0 15.5,2A3.5,3.5 0 0,0 12,5.5A3.5,3.5 0 0,0 8.5,2A6.5,6.5 0 0,0 2,8.5A3.5,3.5 0 0,0 5.5,12A3.5,3.5 0 0,0 2,15.5A6.5,6.5 0 0,0 8.5,22A3.5,3.5 0 0,0 12,18.5A3.5,3.5 0 0,0 15.5,22A6.5,6.5 0 0,0 22,15.5A3.5,3.5 0 0,0 18.5,12M12,16A4,4 0 0,1 8,12A4,4 0 0,1 12,8A4,4 0 0,1 16,12A4,4 0 0,1 12,16M14.5,12A2.5,2.5 0 0,1 12,14.5A2.5,2.5 0 0,1 9.5,12A2.5,2.5 0 0,1 12,9.5A2.5,2.5 0 0,1 14.5,12Z"
+ id="path2"
+ style="fill:#ffffff" />
+</svg>