summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Engel2015-06-13 18:03:12 -0500
committerTroy Engel2015-06-13 18:03:12 -0500
commitcc1143acb6d34e3917a83077e014732a4cacd2fd (patch)
tree24bbf325ee24001c85a5d4bd553460f395acac7d
downloadaur-cc1143acb6d34e3917a83077e014732a4cacd2fd.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rw-r--r--petrified.archinst5
-rw-r--r--petrified.archlog41
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab8df50fafd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = petrified
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/troyengel/petrified
+ changelog = petrified.archlog
+ arch = any
+ license = GPL3
+ options = emptydirs
+ source = https://github.com/troyengel/petrified/archive/v1.0.5.tar.gz
+ md5sums = SKIP
+
+pkgname = petrified
+ pkgdesc = Bash client to update dynamic DNS at freedns.afraid.org
+ install = petrified.archinst
+ depends = util-linux
+ depends = coreutils
+ depends = bash
+ depends = iproute2
+ depends = curl
+ backup = etc/petrified.conf
+
+pkgname = petrified-systemd
+ pkgdesc = Unit files for petrified systemd usage
+ depends = petrified
+ depends = systemd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..308c6967f362
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Troy Engel <troyengel+arch@gmail.com>
+
+pkgbase=petrified
+pkgname=('petrified' 'petrified-systemd')
+pkgver=1.0.5
+pkgrel=1
+changelog=petrified.archlog
+arch=('any')
+url="https://github.com/troyengel/petrified"
+license=('GPL3')
+options=('emptydirs')
+source=("https://github.com/troyengel/petrified/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+package_petrified() {
+ pkgdesc="Bash client to update dynamic DNS at freedns.afraid.org"
+ depends=('util-linux' 'coreutils' 'bash' 'iproute2' 'curl')
+ backup=('etc/petrified.conf')
+ install=petrified.archinst
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ # Install the system bits
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}
+
+package_petrified-systemd() {
+ pkgdesc="Unit files for petrified systemd usage"
+ depends=('petrified' 'systemd')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ # Systemd files
+ make DESTDIR="${pkgdir}" PREFIX=/usr install-systemd
+}
diff --git a/petrified.archinst b/petrified.archinst
new file mode 100644
index 000000000000..a62183c21e41
--- /dev/null
+++ b/petrified.archinst
@@ -0,0 +1,5 @@
+
+pre_remove() {
+ rm -f /var/cache/petrified/lastip.dat 2>/dev/null
+}
+
diff --git a/petrified.archlog b/petrified.archlog
new file mode 100644
index 000000000000..93509913d852
--- /dev/null
+++ b/petrified.archlog
@@ -0,0 +1,41 @@
+2015-03-08 Troy Engel <troyengel+arch@gmail.com>
+ * 1.0.5-1 :
+ Version 1.0.5
+ Migrate PKGBUILD to use all Makefile targets
+ Use SKIP for md5sum to make github tagging/release easier
+
+2014-12-01 Troy Engel <troyengel+arch@gmail.com>
+ * 1.0.4-1 :
+ Version 1.0.4
+
+2014-11-24 Troy Engel <troyengel+arch@gmail.com>
+ * 1.0.3-1 :
+ Version 1.0.3
+ Add new man page and README.pod, deprecate README.md
+
+2014-11-22 Troy Engel <troyengel+arch@gmail.com>
+ * 1.0.2-3 :
+ Fix PKGBUILD optdepends
+
+ * 1.0.2-2 :
+ Fix PKGBUILD weirdness
+
+ * 1.0.2-1 :
+ Version 1.0.2
+ Add petrified-systemd subpackage
+ Add packaging changelog
+ Move examples to extra/ in doc dir
+ Logrotate config is no longer installed system-wide
+
+ * 1.0.1-2 :
+ Convert PKGBUILD to use tagged download from Github
+
+2014-09-07 Troy Engel <troyengel+arch@gmail.com>
+ * 1.0.1-1 :
+ Version 1.0.1
+
+ * 1.0-2 :
+ Fixing lograte and some other things
+
+ * 1.0-1 :
+ Initial release