summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2024-02-23 08:21:23 +0100
committerMartin Diehl2024-02-23 08:21:23 +0100
commit11875cbb74fad5b875ed2b549b6d713bcb8d525c (patch)
treec30a61ce1a570532d2df53f02dcc3fc7ae685e74
parent06fa989d48bf3821dd7035779842da7ea45daa96 (diff)
downloadaur-11875cbb74fad5b875ed2b549b6d713bcb8d525c.tar.gz
fixed logic to skip tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d9cf6bb89d1..1628779e055b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.20.4
- pkgrel = 2
+ pkgrel = 3
url = https://petsc.org
install = petsc.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 172df4aeeede..c42b49631806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgver=3.20.4
-pkgrel=2
+pkgrel=3
pkgname=petsc
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
@@ -91,10 +91,11 @@ check() {
cd ${srcdir}/${pkgname}-${pkgver}
export OMPI_MCA_plm_rsh_agent=sh
- if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
- PYTHONPATH=${srcdir}/tmp/${_install_dir}/lib:${PYTHONPATH} make check
+ export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ if [ -z "$(ldconfig -p | grep libamdhip64.so)" ] || [ -z "$(ldconfig -p | grep libucc.so)" ]; then
+ echo "skipping tests"
else
- export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ PYTHONPATH=${srcdir}/tmp/${_install_dir}/lib:${PYTHONPATH} make check
fi
}