summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2019-02-10 20:48:56 +0100
committerMartin Diehl2019-02-10 20:51:37 +0100
commit5500db7716a43725ffcb59729da4cd03b455f66a (patch)
tree8d34c7dc53b859de9f15edd925a2680acc2979af
parent49d6b29b20f140df44fe60b9645dfa972bf59cf8 (diff)
downloadaur-5500db7716a43725ffcb59729da4cd03b455f66a.tar.gz
using trilinos/petsc if found
-rw-r--r--PKGBUILD7
-rw-r--r--test_optdepends.sh6
2 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbe04d5697ef..f82ff961f94e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Andreas Bilke <abilke at cosy dot sbg dot ac dot at>
+# Maintainer: Martin Diehl <m dot diehl at mpie dot de>
+# Contributor: Andreas Bilke <abilke at cosy dot sbg dot ac dot at>
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
pkgver=3.10.3
-pkgrel=1
+pkgrel=2
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -31,7 +32,7 @@ install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-${pkgver/_/-}.tar.gz
test_optdepends.sh)
sha256sums=('cd106babbae091604fee40c258737c84dec048949be779eaef5a745df3dc8de4'
- 'b737cc58ffb581c68072cf978bf4de3eaff8318c7a1e65c174d7ffe802ed427b')
+ '849b029612312ee5baae43507e56aa32a2b2cb7a6cc4a0b432eb7354dec794d7')
_install_dir=/opt/petsc/${_config}
_petsc_arch="arch-${_config}"
diff --git a/test_optdepends.sh b/test_optdepends.sh
index edc2d79fd9e9..7e584b8a0fce 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -87,10 +87,10 @@ if [ -f "${PASTIX_CONF}" ]; then
fi
# Add trilinos support
-if [ "${TRILINOS_DIR}" ]; then
- CONFOPTS="${CONFOPTS} --with-ml-dir=${TRILINOS_DIR}"
+if [ -f "/usr/lib/libml.so" ]; then
+ CONFOPTS="${CONFOPTS} --with-ml=1"
# Add boost support (may be useful for trilinos)
- #CONFOPTS="${CONFOPTS} --with-boost=1"
+ CONFOPTS="${CONFOPTS} --with-boost=1"
fi
echo "${CONFOPTS}"