summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2021-09-21 17:43:23 +0200
committerMartin Diehl2021-09-21 17:43:23 +0200
commit6aae5ca48028af54af7d100465c0da946b056950 (patch)
tree5303cab6d2ea1d6090a73e1a9755ffb8d3bb9382
parent009bac4304b20aa29103a0f6211ba44f424e8e25 (diff)
downloadaur-6aae5ca48028af54af7d100465c0da946b056950.tar.gz
numpy is a dependency (for petsc4py)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a1c3fe9513f..ad2848b7a21a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.15.4
- pkgrel = 2
+ pkgrel = 3
url = https://www.mcs.anl.gov/petsc
install = petsc.install
arch = i686
@@ -10,7 +10,7 @@ pkgbase = petsc
makedepends = gcc
makedepends = gcc-fortran
makedepends = cmake
- depends = python
+ depends = python-numpy
depends = openmpi
depends = boost
depends = lapack
@@ -26,6 +26,7 @@ pkgbase = petsc
optdepends = fftw: support for the FFTW fast Fourier transform
optdepends = triangle: support for the two-dimensional quality mesh generator and Delaunay triangulator
optdepends = suitesparse: support for the suitesparse sparse matrix libraries
+ provides = petsc4py
options = staticlibs
source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-3.15.4.tar.gz
source = test_optdepends.sh
diff --git a/PKGBUILD b/PKGBUILD
index ff259a469736..16fe06c51a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
pkgver=3.15.4
-pkgrel=2
+pkgrel=3
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -14,7 +14,7 @@ arch=('i686' 'x86_64')
url="https://www.mcs.anl.gov/petsc"
license=('BSD')
options=(staticlibs)
-depends=('python' 'openmpi' 'boost' 'lapack')
+depends=('python-numpy' 'openmpi' 'boost' 'lapack')
makedepends=('gcc' 'gcc-fortran' 'cmake')
provides=('petsc4py')
optdepends=('trilinos: support for trilinos'