summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2018-09-04 10:22:39 -0300
committerLucas Heitzmann Gabrielli2018-09-04 10:22:39 -0300
commita1ee747a4dd56a7cc0b6225ef8be6d9f985d12b5 (patch)
tree0920954dcdcd293d8c67eae9f3a6c50c90cdf168
parente7f714e82ed66708e0494c05ea7335deb4a71a34 (diff)
downloadaur-a1ee747a4dd56a7cc0b6225ef8be6d9f985d12b5.tar.gz
Fix hypre detection
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--test_optdepends.sh4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c91e7853d76..4d481cc2788b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.9.3
- pkgrel = 2
+ pkgrel = 3
url = https://www.mcs.anl.gov/petsc/
install = petsc.install
arch = i686
@@ -29,7 +29,7 @@ pkgbase = petsc
source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-3.9.3.tar.gz
source = test_optdepends.sh
sha256sums = 6c7f2c7a28433385d74d647b4934aaeea3c1b3053b207973c9497639b6ebf7c8
- sha256sums = dc5ac9fe550250480dcb97bc4c6b0671296ec1e8794e92fe244785b4d7d3668e
+ sha256sums = b737cc58ffb581c68072cf978bf4de3eaff8318c7a1e65c174d7ffe802ed427b
pkgname = petsc
diff --git a/PKGBUILD b/PKGBUILD
index cf7b4258abc4..6b3a2ce3f549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
pkgver=3.9.3
-pkgrel=2
+pkgrel=3
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -31,7 +31,7 @@ install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-${pkgver/_/-}.tar.gz
test_optdepends.sh)
sha256sums=('6c7f2c7a28433385d74d647b4934aaeea3c1b3053b207973c9497639b6ebf7c8'
- 'dc5ac9fe550250480dcb97bc4c6b0671296ec1e8794e92fe244785b4d7d3668e')
+ 'b737cc58ffb581c68072cf978bf4de3eaff8318c7a1e65c174d7ffe802ed427b')
_install_dir=/opt/petsc/${_config}
_petsc_arch="arch-${_config}"
diff --git a/test_optdepends.sh b/test_optdepends.sh
index bbb44536ca44..edc2d79fd9e9 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -11,8 +11,8 @@ CONFOPTS=""
# Add hypre support
if [ -f "/usr/lib/libHYPRE.so" ]; then
- VERSION_MIN=2.14.2
- VERSION=$(readlink -f '/usr/lib/libHYPRE.so' | sed 's/^.*\.so\.')
+ VERSION_MIN=2.14.0
+ VERSION=$(readlink -f '/usr/lib/libHYPRE.so' | sed -r 's/^.*libHYPRE-(.*)\.so/\1/')
if [ "$VERSION_MIN" = "$(printf '%s\n' "$VERSION_MIN" "$VERSION" | sort -V | head -n1)" ]; then
CONFOPTS="${CONFOPTS} --with-hypre=1"