summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2024-01-29 09:37:58 +0100
committerMartin Diehl2024-01-29 09:38:52 +0100
commitc151291f2307efa5787cd648e4bd69307635c400 (patch)
tree83aaea8042703ed625a07b295f4c8ef46dadc1fb
parentf9ce761212ef7959fb2932c2a3b1cef407a614f4 (diff)
downloadaur-c151291f2307efa5787cd648e4bd69307635c400.tar.gz
fixed typo
thanks to carlosal1015 for reporting
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--test_optdepends.sh5
3 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4afec5321a0c..8acac0396201 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.20.3
- pkgrel = 5
+ pkgrel = 6
url = https://petsc.org
install = petsc.install
arch = i686
@@ -42,6 +42,6 @@ pkgbase = petsc
source = http://web.cels.anl.gov/projects/petsc/download/release-snapshots/petsc-3.20.3.tar.gz
source = test_optdepends.sh
sha512sums = 912538850eeaf6d78c090438f8198963cd787ef7ff3bbc841719b08fc738c7b20b7955850baacca4eada4a97b113492b9111d35afa33918ec52123e2f1a73f9b
- sha512sums = 13e1c625e12ff8a701bf91f4bf5aa7cfe4766821feab32314b2dbf48a2f26c0ea85586e18c3e72a55c4f26c21bb8675896ee0ddd60a9f06cb68814a03d6057ea
+ sha512sums = 6950c072271251d1a2d1938a142004042e961cc3d36193c74c9b6eabcf00cb7e0cd7081095b972e8d5b515762d8493aef511e8d7d2691c23c3bdfc6034338c60
pkgname = petsc
diff --git a/PKGBUILD b/PKGBUILD
index 137e4358e020..0fd2e02a4244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgver=3.20.3
-pkgrel=5
+pkgrel=6
pkgname=petsc
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
@@ -37,7 +37,7 @@ install=petsc.install
source=(http://web.cels.anl.gov/projects/petsc/download/release-snapshots/${pkgname}-${pkgver}.tar.gz
test_optdepends.sh)
sha512sums=('912538850eeaf6d78c090438f8198963cd787ef7ff3bbc841719b08fc738c7b20b7955850baacca4eada4a97b113492b9111d35afa33918ec52123e2f1a73f9b'
- '13e1c625e12ff8a701bf91f4bf5aa7cfe4766821feab32314b2dbf48a2f26c0ea85586e18c3e72a55c4f26c21bb8675896ee0ddd60a9f06cb68814a03d6057ea')
+ '6950c072271251d1a2d1938a142004042e961cc3d36193c74c9b6eabcf00cb7e0cd7081095b972e8d5b515762d8493aef511e8d7d2691c23c3bdfc6034338c60')
_install_dir=/opt/petsc/${_config}
_petsc_arch=arch-${_config}
diff --git a/test_optdepends.sh b/test_optdepends.sh
index 5b51cbc6881b..249b0ded9aac 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -71,12 +71,11 @@ fi
# ML (Trilinos)
if [ -f "/usr/lib/libml.so" ]; then
CONFOPTS="${CONFOPTS} --with-ml=1"
- # Add boost support
- CONFOPTS="${CONFOPTS} --with-boost=1"
+ CONFOPTS="${CONFOPTS} --with-boost=1" # Add boost support (ML requires it)
fi
# Zoltan
-if [ -f "/usr/lib/lizoltan.so" ]; then
+if [ -f "/usr/lib/libzoltan.so" ]; then
CONFOPTS="${CONFOPTS} --with-zoltan=1"
fi