summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2021-09-16 20:53:23 +0200
committerMartin Diehl2021-09-16 20:53:23 +0200
commitd0bf3b108881f34417cca948424533cde847786b (patch)
treea392d321087b752de104ee2e9b0115ed3782a7e1
parentb8d878fa002a4b7c142165b38384d2a348aa3fef (diff)
downloadaur-d0bf3b108881f34417cca948424533cde847786b.tar.gz
simplified
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf519a777fa8..7698304b4efb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,10 +43,11 @@ build() {
cd ${_build_dir}
- unset PETSC_ARCH
+ export PETSC_ARCH=${_petsc_arch}
export PETSC_DIR=${_build_dir}
- CONFOPTS="--with-shared-libraries=1 --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 \
+ CONFOPTS="--with-shared-libraries=1 \
+ --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 \
--with-cc=$(which mpicc) --with-cxx=$(which mpicxx) --with-fc=$(which mpifort)"
CONFOPTS="${CONFOPTS} $(sh ${srcdir}/test_optdepends.sh)"
@@ -54,10 +55,9 @@ build() {
python ./configure \
--with-mpi-f90module-visibility=0 \
--prefix=${_install_dir} \
- --PETSC_ARCH=${_petsc_arch} \
${CONFOPTS}
- make ${MAKEFLAGS} PETSC_DIR=${_build_dir} PETSC_ARCH=${_petsc_arch} all
+ make ${MAKEFLAGS} all
}
check() {