summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2018-05-21 12:39:28 -0300
committerLucas Heitzmann Gabrielli2018-05-21 12:39:28 -0300
commite522557a8013fcd44286f1139f898589b212653c (patch)
tree20e54fdb710d8705faaacbdb4212b2eddf2fff73
parent72fc08731fb66c148f5a709c4d8833dff15ce422 (diff)
downloadaur-e522557a8013fcd44286f1139f898589b212653c.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--petsc.install5
3 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9da296e25141..28c4246ff363 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
- pkgver = 3.9.1
+ pkgver = 3.9.2
pkgrel = 1
url = https://www.mcs.anl.gov/petsc/
install = petsc.install
@@ -20,13 +20,15 @@ pkgbase = petsc
optdepends = metis: support for metis graph partitioning library
optdepends = pastix: support for the pastix solver
optdepends = superlu: support for the superlu sparse solver
+ optdepends = hypre: support for the hypre sparse system solver
optdepends = hdf5: support for the parallel version of hdf5
optdepends = mumps: support for the mumps sparse solver
optdepends = fftw: support for the fftw fast Fourier transform
+ optdepends = suitesparse: support for the suitesparse sparse matrix libraries
options = staticlibs
- source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-3.9.1.tar.gz
+ source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-3.9.2.tar.gz
source = test_optdepends.sh
- sha256sums = 742e838a35d278693e956ed1ca4592c1d663451f6beea0694bf334aeb67681e8
+ sha256sums = ab396ae5dbfff808df1b5648f5ce30f3021ec70faec3d5cd63df324d416ac6ac
sha256sums = c7b0d839c43bbae0405b8b007588debcd0da526e9a999c5933278d347a0900e2
pkgname = petsc
diff --git a/PKGBUILD b/PKGBUILD
index 51a0af5c159f..fa68d2ab246e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
-pkgver=3.9.1
+pkgver=3.9.2
pkgrel=1
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
@@ -16,22 +16,23 @@ options=(staticlibs)
depends=('python2' 'openmpi' 'boost' 'lapack')
makedepends=('gcc' 'gcc-fortran' 'cmake')
optdepends=('trilinos: support for trilinos'
- 'ptscotch: support for ptscotch parallel graph partitioning library'
- 'parmetis: support for parmetis parallel graph partitioning library'
- 'metis: support for metis graph partitioning library'
- 'pastix: support for the pastix solver'
- 'superlu: support for the superlu sparse solver'
- 'hdf5: support for the parallel version of hdf5'
- 'mumps: support for the mumps sparse solver'
- 'fftw: support for the fftw fast Fourier transform'
- )
+ 'ptscotch: support for ptscotch parallel graph partitioning library'
+ 'parmetis: support for parmetis parallel graph partitioning library'
+ 'metis: support for metis graph partitioning library'
+ 'pastix: support for the pastix solver'
+ 'superlu: support for the superlu sparse solver'
+ 'hypre: support for the hypre sparse system solver'
+ 'hdf5: support for the parallel version of hdf5'
+ 'mumps: support for the mumps sparse solver'
+ 'fftw: support for the fftw fast Fourier transform'
+ 'suitesparse: support for the suitesparse sparse matrix libraries'
+ )
install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-${pkgver/_/-}.tar.gz
test_optdepends.sh)
-sha256sums=('742e838a35d278693e956ed1ca4592c1d663451f6beea0694bf334aeb67681e8'
+sha256sums=('ab396ae5dbfff808df1b5648f5ce30f3021ec70faec3d5cd63df324d416ac6ac'
'c7b0d839c43bbae0405b8b007588debcd0da526e9a999c5933278d347a0900e2')
-
_install_dir=/opt/petsc/${_config}
_petsc_arch="arch-${_config}"
@@ -115,6 +116,7 @@ package() {
mkdir -p ${pkgdir}/etc/profile.d
echo "export PETSC_DIR=${_install_dir}" > ${pkgdir}/etc/profile.d/petsc.sh
+ echo "export PETSC_ARCH=${_petsc_arch}" >> ${pkgdir}/etc/profile.d/petsc.sh
chmod +x ${pkgdir}/etc/profile.d/petsc.sh
# show where the shared libraries are
diff --git a/petsc.install b/petsc.install
index 9bbe4bb528e0..1d1c7dbf94c7 100644
--- a/petsc.install
+++ b/petsc.install
@@ -3,6 +3,7 @@ post_install() {
# set the PETSC_DIR
source /etc/profile.d/petsc.sh
export PETSC_DIR=${PETSC_DIR}
+export PETSC_ARCH=${PETSC_ARCH}
noVersion=${1%%-[1-9]}
rootDir=${noVersion/_/-}
@@ -17,4 +18,8 @@ $ cd src/petsc-${rootDir}/; make PETSC_DIR=$PETSC_DIR test
EOF
}
+post_upgrade() {
+post_install
+}
+
# vim:set ts=2 sw=2 et: