summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2024-01-28 10:46:25 +0100
committerMartin Diehl2024-01-28 21:52:24 +0100
commitf9ce761212ef7959fb2932c2a3b1cef407a614f4 (patch)
treed0d386cdd50a0bb6681ec058e29471fc49920c97
parent26ce718b2981ae1ca523e81c277c4fa00f8570d2 (diff)
downloadaur-f9ce761212ef7959fb2932c2a3b1cef407a614f4.tar.gz
cleaning dependencies
- boost is not used by PETSc directly (only needed for third party packages) - mpy4py is strongly recommended for mpi4py - libyaml is available as a system package and used by PETSc - gsl is available as a system package and used by PETSc - netcdf is available as a system package and used by PETSc - libjpeg-turbo is available as a system package and used by PETSc - zfp is available as a system package and used by PETSc - HDF5 and netCDF have zlib support, PETSc requires that and hence, zlib. - bison is only used for building packages, not need for PETSc to find it - cmake is only used for building packages, not need for PETSc to find it - don't depend on trilinos but on trilinos-ml to enable building individual packages from trilinos - new optional dependencies: kokkos and zoltan
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
-rw-r--r--test_optdepends.sh16
3 files changed, 44 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b6eb5fa8915..4afec5321a0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.20.3
- pkgrel = 4
+ pkgrel = 5
url = https://petsc.org
install = petsc.install
arch = i686
@@ -11,29 +11,37 @@ pkgbase = petsc
makedepends = gcc-fortran
makedepends = cmake
makedepends = cython
- depends = python-numpy
depends = openmpi
- depends = boost
depends = lapack
depends = hdf5-openmpi
depends = fftw
depends = superlu
depends = suitesparse
+ depends = libyaml
+ depends = gsl
+ depends = libjpeg-turbo
+ depends = netcdf-openmpi
+ depends = zfp
+ depends = zlib
+ depends = python-numpy
+ depends = python-mpi4py
optdepends = trilinos: support for trilinos
optdepends = hypre: support for HYPRE
+ optdepends = kokkos: support Kokkos
optdepends = metis: support for METIS
optdepends = mumps: support for MUMPS
optdepends = parmetis: support for ParMETIS
optdepends = scalapack: support for ScaLAPACK
optdepends = scotch: support for Scotch
- optdepends = superlu_dist: support for SuperLU_DIST,
+ optdepends = superlu_dist: support for SuperLU_DIST
optdepends = triangle: support for Triangle
- optdepends = trilinos: support for the ML package from Trilinos
+ optdepends = trilinos-ml: support for ML (part of Trilinos)
+ optdepends = zoltan: support for zoltan
provides = petsc4py
options = staticlibs
source = http://web.cels.anl.gov/projects/petsc/download/release-snapshots/petsc-3.20.3.tar.gz
source = test_optdepends.sh
sha512sums = 912538850eeaf6d78c090438f8198963cd787ef7ff3bbc841719b08fc738c7b20b7955850baacca4eada4a97b113492b9111d35afa33918ec52123e2f1a73f9b
- sha512sums = 80dfd422ba16e0fe529b65fd195d825095483282a2b202f03f81c507cfe694ce0ec9db606cbd74ac68d206343818a6aec15d32aea8faceddd1cec756409d5932
+ sha512sums = 13e1c625e12ff8a701bf91f4bf5aa7cfe4766821feab32314b2dbf48a2f26c0ea85586e18c3e72a55c4f26c21bb8675896ee0ddd60a9f06cb68814a03d6057ea
pkgname = petsc
diff --git a/PKGBUILD b/PKGBUILD
index 635b92888e74..137e4358e020 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgver=3.20.3
-pkgrel=4
+pkgrel=5
pkgname=petsc
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
@@ -14,26 +14,30 @@ arch=('i686' 'x86_64')
url="https://petsc.org"
license=('BSD')
options=(staticlibs)
-depends=('python-numpy' 'openmpi' 'boost' 'lapack' 'hdf5-openmpi' 'fftw' 'superlu' 'suitesparse')
+# note: zlib is not really needed by PETSc, but netcdf requires an HDF5 version with zlib
+depends=('openmpi' 'lapack' 'hdf5-openmpi' 'fftw' 'superlu' 'suitesparse' 'libyaml' 'gsl' 'libjpeg-turbo' 'netcdf-openmpi' 'zfp' 'zlib'
+ 'python-numpy' 'python-mpi4py')
makedepends=('gcc' 'gcc-fortran' 'cmake' 'cython')
provides=('petsc4py')
optdepends=('trilinos: support for trilinos'
'hypre: support for HYPRE'
+ 'kokkos: support Kokkos'
'metis: support for METIS'
'mumps: support for MUMPS'
'parmetis: support for ParMETIS'
'scalapack: support for ScaLAPACK'
'scotch: support for Scotch'
- 'superlu_dist: support for SuperLU_DIST',
+ 'superlu_dist: support for SuperLU_DIST'
'triangle: support for Triangle'
- 'trilinos: support for the ML package from Trilinos'
+ 'trilinos-ml: support for ML (part of Trilinos)'
+ 'zoltan: support for zoltan'
)
install=petsc.install
source=(http://web.cels.anl.gov/projects/petsc/download/release-snapshots/${pkgname}-${pkgver}.tar.gz
test_optdepends.sh)
sha512sums=('912538850eeaf6d78c090438f8198963cd787ef7ff3bbc841719b08fc738c7b20b7955850baacca4eada4a97b113492b9111d35afa33918ec52123e2f1a73f9b'
- '80dfd422ba16e0fe529b65fd195d825095483282a2b202f03f81c507cfe694ce0ec9db606cbd74ac68d206343818a6aec15d32aea8faceddd1cec756409d5932')
+ '13e1c625e12ff8a701bf91f4bf5aa7cfe4766821feab32314b2dbf48a2f26c0ea85586e18c3e72a55c4f26c21bb8675896ee0ddd60a9f06cb68814a03d6057ea')
_install_dir=/opt/petsc/${_config}
_petsc_arch=arch-${_config}
@@ -49,8 +53,16 @@ build() {
CONFOPTS="--with-shared-libraries=1 \
--with-petsc4py=1 \
--with-mpi-f90module-visibility=0 \
+ --with-bison=0 \
+ --with-cmake=0 \
--with-mpi-dir=/usr \
+ --with-zfp=1 \
+ --with-netcdf=1 \
+ --with-libjpeg=1 \
+ --with-yaml=1 \
--with-fftw=1 \
+ --with-gsl=1 \
+ --with-zlib=1 \
--with-superlu-lib=-lsuperlu --with-superlu-include=/usr/include/superlu \
--with-suitesparse-include=/usr/include/suitesparse \
--with-suitesparse-lib=[libamd.so,libbtf.so,libcamd.so,libccolamd.so,libcholmod.so,libcolamd.so,libcxsparse.so,libgraphblas.so,libklu.so,libklu_cholmod.so,liblagraph.so,liblagraphx.so,libldl.so,libparu.so,librbio.so,libspex.so,libspqr.so,libsuitesparse_mongoose.so,libsuitesparseconfig.so,libumfpack.so] \
diff --git a/test_optdepends.sh b/test_optdepends.sh
index 0139aac8359b..5b51cbc6881b 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -14,6 +14,11 @@ if [ -f "/usr/lib/pkgconfig/fftw3.pc" ]; then
CONFOPTS="${CONFOPTS} --with-fftw=1"
fi
+# Kokkos
+if [ -f "/usr/lib/libkokkoscore.so" ]; then
+ CONFOPTS="${CONFOPTS} --with-kokkos=1"
+fi
+
# HYPRE
if [ -f "/usr/lib/libHYPRE.so" ]; then
CONFOPTS="${CONFOPTS} --with-hypre-lib=/usr/lib/libHYPRE.so --with-hypre-include=/usr/include/hypre"
@@ -50,7 +55,7 @@ if [ -f /usr/include/scotch.h ]; then
SCOTCH_LIBS="${SCOTCH_LIBS},libbz2.so"
fi
SCOTCH_LIBS="[${SCOTCH_LIBS}]"
- CONFOPTS="${CONFOPTS} --with-ptscotch=1 --with-ptscotch-lib=${SCOTCH_LIBS} --with-ptscotch-include=${SCOTCH_DIR}"
+ CONFOPTS="${CONFOPTS} --with-ptscotch=1"
fi
# SuperLU_DIST
@@ -63,11 +68,16 @@ if [ -f "/usr/lib/libtriangle.so" ]; then
CONFOPTS="${CONFOPTS} --with-triangle=1"
fi
-# Trilinos (ML)
+# ML (Trilinos)
if [ -f "/usr/lib/libml.so" ]; then
CONFOPTS="${CONFOPTS} --with-ml=1"
- # Add boost support (may be useful for trilinos)
+ # Add boost support
CONFOPTS="${CONFOPTS} --with-boost=1"
fi
+# Zoltan
+if [ -f "/usr/lib/lizoltan.so" ]; then
+ CONFOPTS="${CONFOPTS} --with-zoltan=1"
+fi
+
echo "${CONFOPTS}"