summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-12-31 13:31:45 +0100
committerMartin Diehl2023-12-31 14:05:17 +0100
commitfb326bc82c41208093c80054cba8f090fa830869 (patch)
treebbf32838247972469816372865d9f9f0627fcc64
parentc8ebe17f263ea529925fe9d2f99809d4d8d9caf5 (diff)
downloadaur-fb326bc82c41208093c80054cba8f090fa830869.tar.gz
respect user-specific makeflags
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95d661680e50..d832a7f68839 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.20.3
- pkgrel = 1
+ pkgrel = 2
url = https://petsc.org
install = petsc.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index af53ddfaee5d..e22d2310fb1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgver=3.20.3
-pkgrel=1
+pkgrel=2
pkgname=petsc
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
@@ -56,11 +56,21 @@ build() {
--with-hdf5=1 --with-hdf5-fortran-bindings=1 \
$(sh ${srcdir}/test_optdepends.sh)"
- echo ${CONFOPTS}
- python ./configure --prefix=${_install_dir} ${CONFOPTS} \
- --COPTFLAGS='-O3 -march=native' --CXXOPTFLAGS='-O3 -march=native' --FOPTFLAGS='-O3 -march=native'
-
- make ${MAKEFLAGS} all
+ echo './configure' ${CONFOPTS}
+ echo 'CFLAGS='${CFLAGS}
+ echo 'CXXFLAGS='${CXXFLAGS}
+ echo 'FFLAGS='${FFLAGS}
+ echo 'LDFLAGS='${LDFLAGS}
+ echo 'MAKEFLAGS='${MAKEFLAGS}
+
+ ./configure --prefix=${_install_dir} ${CONFOPTS} \
+ "CFLAGS=$CFLAGS" \
+ "CXXFLAGS=$CXXFLAGS" \
+ "FFLAGS=$FFLAGS" \
+ "LDFLAGS=$LDFLAGS" \
+ "MAKEFLAGS=$MAKEFLAGS"
+
+ make all
make DESTDIR=${srcdir}/tmp install
}