summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-01-19 19:59:50 +0100
committerMartin Diehl2023-01-19 19:59:50 +0100
commitff25819a8cbb4c8ac43f98d4d726099c163da206 (patch)
tree265ccb8c80d852b10d838ef6a89056b7880da36e
parent4582923bf433bebf0ac635019396f0b7fe7f12c3 (diff)
downloadaur-ff25819a8cbb4c8ac43f98d4d726099c163da206.tar.gz
support for superlu_DIST
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--test_optdepends.sh5
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3b51112e920..506129321629 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc
pkgdesc = Portable, extensible toolkit for scientific computation
pkgver = 3.18.2
- pkgrel = 2
+ pkgrel = 3
url = https://www.mcs.anl.gov/petsc
install = petsc.install
arch = i686
@@ -26,6 +26,7 @@ pkgbase = petsc
optdepends = scotch: support for Scotch
optdepends = suitesparse: support for SuiteSparse
optdepends = superlu: support for SuperLU
+ optdepends = superlu_dist: support for SuperLU_DIST,
optdepends = triangle: support for Triangle
optdepends = trilinos: support for the ML package from Trilinos
provides = petsc4py
@@ -33,6 +34,6 @@ pkgbase = petsc
source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-3.18.2.tar.gz
source = test_optdepends.sh
sha256sums = 4e055f92f3d5123d415f6f3ccf5ede9989f16d9e1f71cc7998ad244a3d3562f4
- sha256sums = 8e4d2423621d6d676729e803cb813ec88d7cee3624e829180ff380abb9155343
+ sha256sums = 2d02159b405a2599850d8fef390cd2b5250f653d749edd4b5455c78a0124158b
pkgname = petsc
diff --git a/PKGBUILD b/PKGBUILD
index 9ce5d340a561..f644f46b9c95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
pkgver=3.18.2
-pkgrel=2
+pkgrel=3
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -28,6 +28,7 @@ optdepends=('trilinos: support for trilinos'
'scotch: support for Scotch'
'suitesparse: support for SuiteSparse'
'superlu: support for SuperLU'
+ 'superlu_dist: support for SuperLU_DIST',
'triangle: support for Triangle'
'trilinos: support for the ML package from Trilinos'
)
@@ -36,7 +37,7 @@ install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-${pkgver}.tar.gz
test_optdepends.sh)
sha256sums=('4e055f92f3d5123d415f6f3ccf5ede9989f16d9e1f71cc7998ad244a3d3562f4'
- '8e4d2423621d6d676729e803cb813ec88d7cee3624e829180ff380abb9155343')
+ '2d02159b405a2599850d8fef390cd2b5250f653d749edd4b5455c78a0124158b')
_install_dir=/opt/petsc/${_config}
_petsc_arch=arch-${_config}
diff --git a/test_optdepends.sh b/test_optdepends.sh
index 4536bd318310..4e25a5d3d967 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -69,6 +69,11 @@ if [ -f "/usr/lib/pkgconfig/superlu.pc" ]; then
CONFOPTS="${CONFOPTS} --with-superlu-lib=-lsuperlu --with-superlu-include=/usr/include/superlu"
fi
+# SuperLU_DIST
+if [ -f "/usr/lib/pkgconfig/superlu_dist.pc" ]; then
+ CONFOPTS="${CONFOPTS} --with-superlu_dist-lib=-lsuperlu_dist --with-superlu_dist-include=/usr/include/superlu_dist"
+fi
+
# Triangle
if [ -f "/usr/lib/libtriangle.so" ]; then
CONFOPTS="${CONFOPTS} --with-triangle=1"