summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-12-28 22:29:53 -0500
committerCarlos Aznarán Laos2022-12-28 22:29:53 -0500
commitfcade7e5ea951b2384e1f0de091e234ce538d81e (patch)
treebaa20ee09c7b743791744e8c90ae3619281b9da4
parentbbaf7a8340cc9195452d76ac19b9eb337934f1b6 (diff)
downloadaur-fcade7e5ea951b2384e1f0de091e234ce538d81e.tar.gz
Fix conditional statement for scotch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--test_optdepends.sh4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5bcf7465fcb..be4858695c5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = petsc-complex
pkgdesc = Portable, extensible toolkit for scientific computation (complex scalars)
pkgver = 3.18.3
- pkgrel = 1
+ pkgrel = 2
url = https://petsc.org
install = petsc.install
arch = i686
@@ -37,6 +37,6 @@ pkgbase = petsc-complex
source = https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-lite-3.18.3.tar.gz
source = test_optdepends.sh
sha512sums = 35c7ab7fe9cc15d960410ef75d23d41b9ba1bc640306253ebf1e1d81ceef2dde691b792380d5cd9be4268b31c1033e6336936495b3a7f366d9683315d1a15189
- sha512sums = a74128e1867b60c4a286fe3983c6a90242de27673817a4e50fe02789d9d33578241a53aa1e084acbe3ce2104aae3843969c5de3616db20c78ca7e342689d28d4
+ sha512sums = 039ccd9125619ca5f5ceb0bec586c24b40fa01d485a28094de525cd4e66c606b82c6ee5d9713a1b1d6f828b12b57cddaae8368dbe3a9f5c8edcc45175f6c3737
pkgname = petsc-complex
diff --git a/PKGBUILD b/PKGBUILD
index 82547fd1ec3c..9e19ba78bbee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_base=petsc
pkgname=${_base}-complex
pkgver=3.18.3
-pkgrel=1
+pkgrel=2
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -43,7 +43,7 @@ install=${_base}.install
source=(https://ftp.mcs.anl.gov/pub/${_base}/release-snapshots/${_base}-lite-${pkgver}.tar.gz
test_optdepends.sh)
sha512sums=('35c7ab7fe9cc15d960410ef75d23d41b9ba1bc640306253ebf1e1d81ceef2dde691b792380d5cd9be4268b31c1033e6336936495b3a7f366d9683315d1a15189'
- 'a74128e1867b60c4a286fe3983c6a90242de27673817a4e50fe02789d9d33578241a53aa1e084acbe3ce2104aae3843969c5de3616db20c78ca7e342689d28d4')
+ '039ccd9125619ca5f5ceb0bec586c24b40fa01d485a28094de525cd4e66c606b82c6ee5d9713a1b1d6f828b12b57cddaae8368dbe3a9f5c8edcc45175f6c3737')
_install_dir=/opt/${_base}/${_config}
_petsc_arch=arch-${_config}
diff --git a/test_optdepends.sh b/test_optdepends.sh
index b4d37a2e07a8..54e2e4c7ee9e 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -62,8 +62,8 @@ if [ -f "/usr/include/metis.h" ]; then
fi
# Add scotch support
-SCOTCH_DIR="/usr/include/scotch"
-if [ -d "${SCOTCH_DIR}" ]; then
+SCOTCH_DIR="/usr/include"
+if [ -d "/usr/include/scotch.h" ]; then
SCOTCH_LIBS="libesmumps.so,libptscotch.so,libptscotcherr.so,libscotch.so,libscotcherr.so"
# Include bzip2 if scotch was build with bzip2 support
if [ -f /usr/include/bzlib.h ];then