summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2021-09-29 23:14:55 -0500
committereDgar2021-09-29 23:14:55 -0500
commit7cb04930d3a5b4975e97307ce89c43927bcc6ea2 (patch)
treee5dc7e26249a14df7020332d3a6ef11e8f827859
parent2d45841652059d613ca65763f2d2cff899bc82a2 (diff)
downloadaur-7cb04930d3a5b4975e97307ce89c43927bcc6ea2.tar.gz
add patch to fix esmumps bug (fixed by Satish Balay @ petsc-maint)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
-rw-r--r--so.diff13
-rw-r--r--test_optdepends.sh2
4 files changed, 36 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f763cd630d2..d8ceca65764c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = petsc-git
pkgdesc = Portable, extensible toolkit for scientific computation
- pkgver = 3.15.4.39.g3348d10f62a
+ pkgver = 3.15.5
pkgrel = 1
url = https://gitlab.com/petsc/petsc
arch = i686
@@ -26,11 +26,13 @@ pkgbase = petsc-git
depends = openblas
options = !staticlibs
source = git+https://gitlab.com/petsc/petsc.git#branch=release
- source = https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-3.15.4.tar.gz
+ source = https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-3.15.5.tar.gz
source = test_optdepends.sh
+ source = so.diff
sha512sums = SKIP
- sha512sums = b6a1d48aab1c2639a4c1cbd8b313ace253f1c36eedaa3de3508ffbd6060e1def99e2f516ed9bb509307f614b41791d09342e2c2280c0b2c25dda1092b0e569d2
- sha512sums = a4e064c08730058d63120a22c12657a100e5330546d66c44bb85e5bf84df80a23a729b0266af3efce2c8148f0266ddca99eaf9c8ea88d323cebe1d0c18c45d09
+ sha512sums = d6be4488cb5dad9f7928e0966b875f83d4b84a0fd8553fcc9912aed1b7f1fcd3922ec282c30dc8cb0b424e8375b437fe50ce84b76c9c8a28c51efd954f6ed001
+ sha512sums = e45df388b373b5f8c86567f32f0d79ae275a855a7fd3b4bb9c03d6875351633d4064de701644a4aa2f9eff90d63806f714230298149868b2f6d92a4f21e20cb8
+ sha512sums = e79a4a070df882d8cbf302c1b8732fc2fea907cd5bc5c429e4ff4919e45ffef1a0b7abe578c5942bf44bbb34bcabed70029f4f6403fee23b7da3ca7cce29edb4
pkgname = petsc-git
optdepends = boost: Free peer-reviewed portable C++ source libraries
@@ -47,14 +49,14 @@ pkgname = petsc-git
optdepends = opencl-headers: for opencl (GPU computing)
optdepends = opencl: GPU computing
optdepends = openmp: Parallel distributed tasks
- optdepends = png
+ optdepends = libpng
optdepends = scalapack: Parallel memory linear algebra
optdepends = scotch: Partitioning with sparse matrices
optdepends = suitesparse: Sparse matrix library
optdepends = superlu: Subroutines for sparsse linear systems
- optdepends = yaml: configuration files
- provides = petsc=3.15.4
- provides = petsc4py=3.15.4
+ optdepends = libyaml: configuration files
+ provides = petsc=3.15.5
+ provides = petsc4py=3.15.5
conflicts = petsc
pkgname = petsc-doc
diff --git a/PKGBUILD b/PKGBUILD
index 820c514e368a..e65c45adc313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_base=petsc
pkgname=("${_base}"-git "${_base}"-doc)
-pkgver=3.15.4.39.g3348d10f62a
+pkgver=3.15.5
pkgrel=1
_mainver="${pkgver:0:6}"
pkgdesc="Portable, extensible toolkit for scientific computation"
@@ -19,10 +19,12 @@ makedepends=('gcc' 'gcc-fortran' 'cmake' 'sowing' "pkgconf"
'git' 'cython' 'chrpath' "hypre=2.18.2")
source=(git+${url}.git#branch=release
https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-"${_mainver}".tar.gz
- test_optdepends.sh)
+ test_optdepends.sh
+ so.diff)
sha512sums=('SKIP'
- 'b6a1d48aab1c2639a4c1cbd8b313ace253f1c36eedaa3de3508ffbd6060e1def99e2f516ed9bb509307f614b41791d09342e2c2280c0b2c25dda1092b0e569d2'
- 'a4e064c08730058d63120a22c12657a100e5330546d66c44bb85e5bf84df80a23a729b0266af3efce2c8148f0266ddca99eaf9c8ea88d323cebe1d0c18c45d09')
+ 'd6be4488cb5dad9f7928e0966b875f83d4b84a0fd8553fcc9912aed1b7f1fcd3922ec282c30dc8cb0b424e8375b437fe50ce84b76c9c8a28c51efd954f6ed001'
+ 'e45df388b373b5f8c86567f32f0d79ae275a855a7fd3b4bb9c03d6875351633d4064de701644a4aa2f9eff90d63806f714230298149868b2f6d92a4f21e20cb8'
+ 'e79a4a070df882d8cbf302c1b8732fc2fea907cd5bc5c429e4ff4919e45ffef1a0b7abe578c5942bf44bbb34bcabed70029f4f6403fee23b7da3ca7cce29edb4')
_config=linux-c-opt
_install_dir="/usr"
@@ -88,6 +90,10 @@ export OMPI_MCA_mpi_oversubscribe=0
unset PETSC_DIR
export PETSC_ARCH=${_config}
+prepare() {
+ patch -p1 -d "${srcdir}"/"${_base}" -i "${srcdir}"/so.diff
+}
+
pkgver() {
cd "${srcdir}"/"${_base}"
git describe --tags --match '*.*' | tr '-' '.' | sed 's-^v--'
@@ -148,12 +154,12 @@ package_petsc-git() {
"opencl-headers: for opencl (GPU computing)"
"opencl: GPU computing"
"openmp: Parallel distributed tasks"
- "png"
+ "libpng"
"scalapack: Parallel memory linear algebra"
"scotch: Partitioning with sparse matrices"
"suitesparse: Sparse matrix library"
"superlu: Subroutines for sparsse linear systems"
- "yaml: configuration files")
+ "libyaml: configuration files")
provides=(${_base}="${_mainver}" petsc4py="${_mainver}")
conflicts=(${_base})
diff --git a/so.diff b/so.diff
new file mode 100644
index 000000000000..0445c02248a3
--- /dev/null
+++ b/so.diff
@@ -0,0 +1,13 @@
+diff --git a/config/BuildSystem/config/libraries.py b/config/BuildSystem/config/libraries.py
+index 0d93f57fc0..d94932899f 100644
+--- a/config/BuildSystem/config/libraries.py
++++ b/config/BuildSystem/config/libraries.py
+@@ -133,7 +133,7 @@ class Configure(config.base.Configure):
+ # remove duplicate -L, -Wl,-rpath options - and only consecutive -l options
+ if j in newldflags and any([j.startswith(flg) for flg in dupflags]): continue
+ if newlibs and j == newlibs[-1]: continue
+- if j.startswith('-l') or j.endswith('.lib') or j.endswith('.a') or j.endswith('.o') or j == '-Wl,-Bstatic' or j == '-Wl,-Bdynamic' or j == '-Wl,--start-group' or j == '-Wl,--end-group':
++ if j.startswith('-l') or j.endswith('.lib') or j.endswith('.a') or j.endswith('.so') or j.endswith('.o') or j == '-Wl,-Bstatic' or j == '-Wl,-Bdynamic' or j == '-Wl,--start-group' or j == '-Wl,--end-group':
+ newlibs.append(j)
+ else:
+ newldflags.append(j)
diff --git a/test_optdepends.sh b/test_optdepends.sh
index 8803ccdb8f97..b26efc2cf140 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -228,7 +228,7 @@ if [ -f "${PTSCOTCH_SO}" ]; then
SCOTCH_LIBS=$(pacman -Qlq scotch | grep '.so$'| tr '\n' ',')
# Check if libscotch was compiled with bz2
if [ ! -z "$(nm -D $(find_so libscotch.so) | grep bz)" ]; then
- CONFOPTS="${CONFOPTS}$(find_so libbz2.so)"
+ SCOTCH_LIBS="${SCOTCH_LIBS}$(find_so libbz2.so)"
else
# Remove trailing ,
SCOTCH_LIBS="${SCOTCH_LIBS%%,}"