summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2021-09-23 14:20:16 -0500
committereDgar2021-09-23 14:26:24 -0500
commit9ea9b0419bfe86269da385eecad76446f6621dd6 (patch)
treeed32d1a7a7b06cc346c0f4ebbe9eae40143e7cbd
parentd8aa242b76075f92d225789a712db168e3484888 (diff)
downloadaur-9ea9b0419bfe86269da385eecad76446f6621dd6.tar.gz
use Python list notation for blaslapack
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--test_optdepends.sh9
3 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20133e0151ba..5bfb3faaa314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = petsc-git
pkgdesc = Portable, extensible toolkit for scientific computation
- pkgver = 3.15.4.33.g0bac13e0fe9
+ pkgver = 3.15.4.37.g17c486c0fcd
pkgrel = 1
url = https://gitlab.com/petsc/petsc
arch = i686
@@ -30,7 +30,7 @@ pkgbase = petsc-git
source = test_optdepends.sh
sha512sums = SKIP
sha512sums = b6a1d48aab1c2639a4c1cbd8b313ace253f1c36eedaa3de3508ffbd6060e1def99e2f516ed9bb509307f614b41791d09342e2c2280c0b2c25dda1092b0e569d2
- sha512sums = 26145ebce4c3c2a418488e1412579ea56744e9da07f0f6ebc9e457a14ca8679d207135b36a351e5e49efa5083ea6506516f6bfb2aef978d3986fcde7ebe8d4c0
+ sha512sums = 77b257ea28a9f109c48c8447ab2db4204f6dba715626f15e916ec8f54c18d01588aa4d760c30b9a58659eefddafc7b54319525f8d89a693fd5305144eba7fc28
pkgname = petsc-git
optdepends = boost: Free peer-reviewed portable C++ source libraries
diff --git a/PKGBUILD b/PKGBUILD
index ae9662537606..593bed49ca9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,12 +19,10 @@ makedepends=('gcc' 'gcc-fortran' 'cmake' 'sowing' "pkgconf"
'git' 'cython' 'chrpath' "hypre=2.18.2")
source=(git+${url}.git#branch=release
https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-"${_mainver}".tar.gz
- test_optdepends.sh
- blaslapack_download.patch)
+ test_optdepends.sh)
sha512sums=('SKIP'
'b6a1d48aab1c2639a4c1cbd8b313ace253f1c36eedaa3de3508ffbd6060e1def99e2f516ed9bb509307f614b41791d09342e2c2280c0b2c25dda1092b0e569d2'
- '3b3b6de71e65e8b9806e16f9a2c839e6022ce0d6860606ec38604377b946e843c7227385c46d1f13195266575dc381b6a391cba33fc754ff461fed650ac1d332'
- 'af899ea1d06bf6d4cee1c1fe86902ba2772d1001caf00e89363c6217fed9dd837588ee6f7f827ca8b8fd2a01316fbcd73d98874e28d452af71b9598127b6f179')
+ 'e9ca635fde40291ae78c3985c03fe68f97ce4c2d15674ba776a3d3f820ef0d82b19f62b51c285f849ea6baa1bb67b6a89dea17c398f0ce0b65b12c0a3ffc0829')
_config=linux-c-opt
_install_dir="/usr"
@@ -89,10 +87,6 @@ export OMPI_MCA_opal_cuda_support=0
unset PETSC_DIR
export PETSC_ARCH=${_config}
-prepare () {
- patch -p1 -i "${srcdir}"/blaslapack_download.patch
-}
-
pkgver() {
cd "${srcdir}"/"${_base}"
git describe --tags --match '*.*' | tr '-' '.' | sed 's-^v--'
diff --git a/test_optdepends.sh b/test_optdepends.sh
index 45796e7cf23b..b979a4bd529e 100644
--- a/test_optdepends.sh
+++ b/test_optdepends.sh
@@ -136,11 +136,10 @@ OPENBLAS_SO="$(find_so libopenblas.so)"
LAPACK_SO="$(find_so liblapack.so)"
if [ -f "${BLAS_SO}" ] && [ -f "${OPENBLAS_SO}" ] \
&& [ -f "${LAPACK_SO}" ]; then
- CONFOPTS="${CONFOPTS} --with-openblas=1"
- OPENBLAS_INC="$(pkgconf ${ONLY_INC} openblas)"
- OPENBLAS_INC="${OPENBLAS_INC//-I/}"
- CONFOPTS="${CONFOPTS} --with-openblas-lib=${OPENBLAS_SO}"
- CONFOPTS="${CONFOPTS} --with-openblas-include=${OPENBLAS_INC}"
+ # With help from Satish Balay
+ # @ 3.15.4.33.g0bac13e0fe9 2021-09-21
+ # nm -AoD /usr/lib64/libopenblas.so | grep dgetrs_
+ CONFOPTS="${CONFOPTS} --with-blaslapack-lib=[${LAPACK_SO},${BLAS_SO}]"
fi
# OpenCL: GPU computing