summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2021-09-26 13:39:15 -0500
committereDgar2021-09-26 13:39:15 -0500
commite4ebcf1b54558918e6b4563a60c4c74ad8a9efaa (patch)
treeb4ab4dcde31cbae5ade71bda4d1a954956e40ec2
parent9ea9b0419bfe86269da385eecad76446f6621dd6 (diff)
downloadaur-e4ebcf1b54558918e6b4563a60c4c74ad8a9efaa.tar.gz
trying to disable "mpiexec -oversubscribe"
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 593bed49ca9e..804a7610963e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ source=(git+${url}.git#branch=release
test_optdepends.sh)
sha512sums=('SKIP'
'b6a1d48aab1c2639a4c1cbd8b313ace253f1c36eedaa3de3508ffbd6060e1def99e2f516ed9bb509307f614b41791d09342e2c2280c0b2c25dda1092b0e569d2'
- 'e9ca635fde40291ae78c3985c03fe68f97ce4c2d15674ba776a3d3f820ef0d82b19f62b51c285f849ea6baa1bb67b6a89dea17c398f0ce0b65b12c0a3ffc0829')
+ '77b257ea28a9f109c48c8447ab2db4204f6dba715626f15e916ec8f54c18d01588aa4d760c30b9a58659eefddafc7b54319525f8d89a693fd5305144eba7fc28')
_config=linux-c-opt
_install_dir="/usr"
@@ -84,6 +84,7 @@ generic_flags="${generic_flags} -O2"
export LANG=C
export OMPI_MCA_opal_cuda_support=0
+export OMPI_MCA_mpi_oversubscribe=0
unset PETSC_DIR
export PETSC_ARCH=${_config}
@@ -109,8 +110,7 @@ build() {
--FFLAGS="$generic_flags"
--MAKEFLAGS=${MAKEFLAGS}
--LDFLAGS=${LDFLAGS}
- --with-environment-variables=0
- --disable-environment-variables=1
+ --with-environment-variables=1
--with-cxx-dialect=auto
--with-mpi=1
--with-pic=1
@@ -124,6 +124,7 @@ build() {
cd "${srcdir}"/"${_base}"
python ./configure ${CONFOPTS[@]}
make -s ${MAKEFLAGS} all
+ # MPIEXEC="$(which mpiexec) --nooversubscribe" make -s ${MAKEFLAGS} all
}
check() {