summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-06-07 00:01:04 +0200
committerCarl Smedstad2023-08-07 07:52:11 +0200
commit05ce3885a2a6655b80238a7ba2421022f8b4959c (patch)
tree23a8565830abebb0ab747daaeaad6c0fb7fcd93e
parent05a9a7bada61c2cec8831a97e2ae84c3528d71d1 (diff)
downloadaur-05ce3885a2a6655b80238a7ba2421022f8b4959c.tar.gz
Publish version 1.8.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
-rw-r--r--remove-demo-notice.patch40
4 files changed, 49 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27e5ec0cec6..ac9388ddc40a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pev2-electron
pkgdesc = Postgres Explain Visualizer 2, using the system Electron package
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dalibo/pev2
arch = any
license = custom:PostgreSQL
@@ -10,8 +10,10 @@ pkgbase = pev2-electron
source = pev2-electron-1.8.0.tar.gz::https://github.com/dalibo/pev2/archive/refs/tags/v1.8.0.tar.gz
source = pev2.sh
source = pev2.desktop
+ source = remove-demo-notice.patch
sha256sums = a13f3c9825c482f4de072250ee7fc0e057fc73057c4b3f82440b4d4e658abb2e
sha256sums = d4361d563a1c199b5887154ac5f4d8009dc2c882b409c8f4bbf00281a2e910e4
sha256sums = 219229650df88bf6f8ffc0bb53bf2986a479d0144c0fa93949996b58ed4e7d8e
+ sha256sums = ebce556db5f905ecb26dca709bde78f94ba5ea325a934436099e51d76165f640
pkgname = pev2-electron
diff --git a/.gitignore b/.gitignore
index 4bdf19f355dc..935044d5d833 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@
!.SRCINFO
!pev2.desktop
!pev2.sh
+!remove-demo-notice.patch
diff --git a/PKGBUILD b/PKGBUILD
index cff07c94c772..db1215ca96ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pev2-electron
_name=pev2
pkgver=1.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Postgres Explain Visualizer 2, using the system Electron package"
arch=(any)
url="https://github.com/dalibo/pev2"
@@ -15,11 +15,13 @@ source=(
"$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
"pev2.sh"
"pev2.desktop"
+ "remove-demo-notice.patch"
)
sha256sums=(
'a13f3c9825c482f4de072250ee7fc0e057fc73057c4b3f82440b4d4e658abb2e'
'd4361d563a1c199b5887154ac5f4d8009dc2c882b409c8f4bbf00281a2e910e4'
'219229650df88bf6f8ffc0bb53bf2986a479d0144c0fa93949996b58ed4e7d8e'
+ 'ebce556db5f905ecb26dca709bde78f94ba5ea325a934436099e51d76165f640'
)
_archive="$_name-$pkgver"
@@ -27,6 +29,8 @@ _archive="$_name-$pkgver"
prepare() {
cd "$_archive"
+ patch --forward --strip=1 --input="$srcdir/remove-demo-notice.patch"
+
sed -i 's/.*husky.*//' package.json
}
diff --git a/remove-demo-notice.patch b/remove-demo-notice.patch
new file mode 100644
index 000000000000..194ea8660750
--- /dev/null
+++ b/remove-demo-notice.patch
@@ -0,0 +1,40 @@
+diff --unified --recursive --text pev2-1.8.0.orig/example/src/views/HomeView.vue pev2-1.8.0/example/src/views/HomeView.vue
+--- pev2-1.8.0.orig/example/src/views/HomeView.vue 2023-03-21 08:12:20.000000000 +0100
++++ pev2-1.8.0/example/src/views/HomeView.vue 2023-06-06 23:53:35.489859399 +0200
+@@ -154,15 +154,6 @@
+ <template>
+ <main-layout>
+ <div class="container">
+- <div class="alert alert-warning">
+- This is the demo application for
+- <a href="https://github.com/dalibo/pev2">PEV2</a>. It is serverless and
+- doesn't store your plans.
+- <br />
+- Please consider using
+- <a href="https://explain.dalibo.com">explain.dalibo.com</a> instead if
+- you want to save or share your plans.
+- </div>
+ <div class="row">
+ <div class="col d-flex">
+ <div class="text-muted">
+diff --unified --recursive --text pev2-1.8.0.orig/package.json pev2-1.8.0/package.json
+--- pev2-1.8.0.orig/package.json 2023-03-21 08:12:20.000000000 +0100
++++ pev2-1.8.0/package.json 2023-06-06 23:52:45.559685767 +0200
+@@ -22,7 +22,7 @@
+ "preview": "vite preview --port 5050",
+ "typecheck": "vue-tsc --noEmit",
+ "lint": "eslint . --ext .vue,.js,.jsx,.cjs,.mjs,.ts,.tsx,.cts,.mts --fix --ignore-path .gitignore",
+- "prepare": "husky install",
++
+ "test": "jest"
+ },
+ "dependencies": {
+@@ -59,7 +59,7 @@
+ "@vue/tsconfig": "^0.1.3",
+ "eslint": "^8.5.0",
+ "eslint-plugin-vue": "^8.5.0",
+- "husky": "^7.0.0",
++
+ "jest": "^27.5.1",
+ "lint-staged": "^12.4.0",
+ "prettier": "^2.5.1",