summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2020-04-03 17:59:56 +0200
committerSebastian Wiesner2020-04-03 18:12:27 +0200
commit28857334cb0d08a0ae778eb2cf883b470f7a25de (patch)
treed41222ed7a015fe5491599e9cb75fc52663cde15
downloadaur-28857334cb0d08a0ae778eb2cf883b470f7a25de.tar.gz
Create package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9cda55c3ec5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pexip-infinity-connect-bin
+ pkgdesc = Pexip Infinity Connect App
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://www.pexip.com/apps
+ arch = x86_64
+ license = custom
+ depends = nss
+ depends = xdg-utils
+ depends = gtk3
+ depends = libxss
+ source = https://dl.pexip.com/connect/nextgen/1.6/pexip-infinity-connect_1.6.0-52920.61.0_linux-x64.deb
+ md5sums = 94e6d372bbcfa72cfe7d677c5f1b79fe
+ sha1sums = b6cecdb29dc5e3e28e3c2b9051e89b6f1d5d8f22
+ sha512sums = fc91c919fce22faf864ec693a268b18ddf455f40ca3d4b48c99dcaa583e44c5c63fdaf9369217478f05a382f6a217b4e79e93d1ea10dc05ed22290b90e4399ea
+
+pkgname = pexip-infinity-connect-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed0529001da3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
+
+_pkgname=pexip-infinity-connect
+pkgname="${_pkgname}-bin"
+pkgdesc='Pexip Infinity Connect App'
+_buildno_in_url='52920.61.0'
+pkgver="1.6.0"
+pkgrel=1
+url='https://www.pexip.com/apps'
+license=('custom')
+arch=('x86_64')
+depends=('nss' 'xdg-utils' 'gtk3' 'libxss')
+source=("https://dl.pexip.com/connect/nextgen/${pkgver%.*}/${_pkgname}_${pkgver}-${_buildno_in_url}_linux-x64.deb")
+md5sums=('94e6d372bbcfa72cfe7d677c5f1b79fe')
+sha1sums=('b6cecdb29dc5e3e28e3c2b9051e89b6f1d5d8f22')
+sha512sums=('fc91c919fce22faf864ec693a268b18ddf455f40ca3d4b48c99dcaa583e44c5c63fdaf9369217478f05a382f6a217b4e79e93d1ea10dc05ed22290b90e4399ea')
+
+package() {
+ tar --no-same-owner -xJC "$pkgdir" -f data.tar.xz
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ for license_file in LICENSE LICENSES.chromium.html; do
+ mv "$pkgdir/usr/lib/pexip-infinity-connect_linux-x64/${license_file}" \
+ "$pkgdir/usr/share/licenses/$pkgname"
+ done
+
+ ln -s /usr/lib/pexip-infinity-connect_linux-x64/pexip-infinity-connect \
+ "$pkgdir/usr/bin/pexip-infinity-connect"
+}