summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron E2019-07-20 13:50:09 -0700
committerAaron E2019-07-20 13:50:09 -0700
commit59a5ee1b4115ad2434a4dbabc4272a026bfcbd3c (patch)
treee70dd8c4e59bcd7159297e71d25e5bb9f61b9a38
downloadaur-pfc-git.tar.gz
Add files
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE.md22
-rw-r--r--PKGBUILD55
-rw-r--r--pfc-git.install48
4 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea8f0f95e60d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pfc-git
+ pkgdesc = a cli-based modular toolkit for pentesting and reconnaissance
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Arinerron/pfc
+ arch = i686
+ arch = x86_64
+ depends = jdk8-openjdk
+ depends = jre8-openjdk
+ source = pfc-git-1.0::git+https://github.com/Arinerron/pfc.git#branch=master
+ md5sums = SKIP
+
+pkgname = pfc-git
+
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..5d047515abaf
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,22 @@
+MIT License
+
+Copyright (c) 2017 Arinerron
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bd47557264c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Aaron Esau <pfc@aaronesau.com>
+pkgname="pfc-git"
+pkgver="1.0"
+pkgrel="1"
+arch=("i686" "x86_64")
+md5sums=("SKIP")
+url="https://github.com/Arinerron/pfc"
+pkgdesc="a cli-based modular toolkit for pentesting and reconnaissance"
+source=("${pkgname}-${pkgver}::git+https://github.com/Arinerron/pfc.git#branch=master")
+depends=("jdk8-openjdk" "jre8-openjdk")
+
+rinstall() {
+ if [ -f "$1" ]; then
+ install -D "$1" "$2/" "$3" "$4"
+ return 0
+ fi
+
+ for file in $(find "$1" -type f -printf '%P\n'); do
+ install -D "$1/$file" "$2/$file" "$3" "$4"
+ done
+
+ return 0
+}
+
+prepare() {
+ # pre_build
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+}
+
+build() {
+ # build
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sh compile.sh
+}
+
+check() {
+ # post_build
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+}
+
+package() {
+ # "movements"
+ # ensure target directories exist
+ mkdir -p "$pkgdir//usr/share/pfc"
+ mkdir -p "$pkgdir//usr/bin/"
+
+ # copy files over and change perms
+ rinstall "${srcdir}/${pkgname}-${pkgver}/." "${pkgdir}//usr/share/pfc" --mode=755 --owner="root" --group="root"
+ rinstall "${srcdir}/${pkgname}-${pkgver}/pfc" "${pkgdir}//usr/bin/" --mode=755 --owner="root" --group="root"
+}
diff --git a/pfc-git.install b/pfc-git.install
new file mode 100644
index 000000000000..8b2f923ed14c
--- /dev/null
+++ b/pfc-git.install
@@ -0,0 +1,48 @@
+
+pre_install {
+ # pre_install
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+
+}
+
+post_install {
+ # post_install
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+
+}
+
+pre_upgrade {
+ # pre_upgrade
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+
+}
+
+post_upgrade {
+ # post_upgrade
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+
+}
+
+pre_remove {
+ # pre_remove
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+
+}
+
+post_remove {
+ # post_remove
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+
+}