summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-03-09 04:47:21 +0800
committerYen Chi Hsuan2015-03-09 04:47:21 +0800
commitf137f5f1f6b664899c472ae833bdb416dbf8af6a (patch)
treec6853b7331f5c6a032944456db83d14108e538e2
downloadaur-f137f5f1f6b664899c472ae833bdb416dbf8af6a.tar.gz
Adopt and update pfff-git
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3eb1f173d4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pfff-git
+ pkgdesc = tools and APIs for code analysis, visualization and transformation
+ pkgver = v0.28.1.r459.g7edb85d
+ pkgrel = 1
+ url = https://github.com/facebook/pfff
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = ocaml
+ makedepends = ocaml-findlib
+ makedepends = camlp4
+ optdepends = gtk2: required by codegraph and codemap
+ provides = pfff
+ conflicts = pfff
+ options = !makeflags
+ options = staticlibs
+ source = git+https://github.com/facebook/pfff
+ md5sums = SKIP
+
+pkgname = pfff-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dd1c915b05ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/pfff
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e18eaa46cf57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
+# Contributor: David Stelter <david.stelter@gmail.com>
+# Contributor: Francisco Lopes <chico.lopes@gmail.com>
+
+_pkgname=pfff
+pkgname="$_pkgname-git"
+pkgver=v0.28.1.r459.g7edb85d
+pkgrel=1
+pkgdesc='tools and APIs for code analysis, visualization and transformation'
+arch=('x86_64')
+url='https://github.com/facebook/pfff'
+license=('LGPL2.1')
+optdepends=('gtk2: required by codegraph and codemap')
+makedepends=('git' 'ocaml' 'ocaml-findlib' 'camlp4')
+source=('git+https://github.com/facebook/pfff.git')
+options=(!makeflags staticlibs) # parallel build fails, need *.a files
+md5sums=('SKIP')
+conflicts=(pfff)
+provides=(pfff)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./configure --prefix=/usr
+ make depend
+ make
+ make opt
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR=$pkgdir install
+ mkdir -p ${pkgdir}/usr/lib/ocaml # ocamlfind won't do this itself...
+ make OCAMLFIND_LDCONF=${pkgdir}/tmp/ld.conf OCAMLFIND_DESTDIR=${pkgdir}/usr/lib/ocaml install-findlib
+}