summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-09 13:51:05 -0400
committerKyle Keen2015-08-09 13:51:05 -0400
commit5cc17df921940b9fcd1bdb491380fb71fdbc449c (patch)
tree9569efd74572b86a2a7f0383f6161c5f33d1a2a1
downloadaur-5cc17df921940b9fcd1bdb491380fb71fdbc449c.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a755c50f6d15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pforth-git
+ pkgdesc = A portable implementation of the Forth programming language written in ANSI C
+ pkgver = c232a93
+ pkgrel = 1
+ url = http://www.softsynth.com/pforth/
+ arch = any
+ license = custom
+ makedepends = git
+ provides = pforth
+ conflicts = pforth
+ source = git+https://github.com/philburk/pforth.git
+ md5sums = SKIP
+
+pkgname = pforth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fd4f14904bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Nicola Fontana <ntd@entidi.it>
+
+pkgname=pforth-git
+pkgver=c232a93
+pkgrel=1
+pkgdesc='A portable implementation of the Forth programming language written in ANSI C'
+arch=(any)
+url='http://www.softsynth.com/pforth/'
+license=(custom)
+depends=()
+makedepends=('git')
+conflicts=('pforth')
+provides=('pforth')
+source=()
+source=('git+https://github.com/philburk/pforth.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ local cflags='-DPF_DEFAULT_DICTIONARY=\"/usr/share/pforth/pforth.dic\"'
+
+ # --std=c89 implicitely declares off_t I/O functions such as ftello
+ cflags="$cflags --std=c89"
+
+ # -D_BSD_SOURCE=1 is defined to avoid the ‘ECHOCTL’ undeclared error
+ cflags="$cflags -D_BSD_SOURCE=1"
+
+ cd "$srcdir/pforth"
+ make -j 1 -f build/unix/Makefile all \
+ SRCDIR=. FULL_WARNINGS= DEBUGOPTS= EXTRA_CCOPTS="$cflags"
+}
+
+package() {
+ local prefix="$pkgdir/usr"
+
+ cd "$srcdir/pforth"
+
+ install -Dm755 pforth "$prefix/bin/pforth"
+ install -Dm755 pforth_standalone "$prefix/bin/pforth_standalone"
+ install -Dm644 pforth.dic "$prefix/share/pforth/pforth.dic"
+ install -Dm644 readme.txt "$prefix/share/pforth/README"
+ install -Dm644 releases.txt "$prefix/share/pforth/NEWS"
+}
+
+# vim:set ts=2 sw=2 et: