summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIliya Ivanov2020-04-24 13:07:50 +0300
committerIliya Ivanov2020-04-24 13:07:50 +0300
commitb03049317f1c968480efa9611a871c95fdfb047e (patch)
treeeb0d5ebc4f60a1998269dc796116f26f8b483682
downloadaur-pg_show_plans.tar.gz
v 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD28
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eed2e95530af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pg_show_plans
+ pkgdesc = Shows the query plans of all currently running SQL statements
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.cybertec-postgresql.com/en/products/pg-show-plans/
+ arch = x86_64
+ license = The PostgreSQL Licence
+ depends = postgresql
+ backup =
+ source = https://github.com/cybertec-postgresql/pg_show_plans/archive/REL_EE_1_0_0.tar.gz
+ sha256sums = 775a0329d92d7a467eba324d89c5629a3dafe887dd4ce1b9fc35b0d2ec396c73
+
+pkgname = pg_show_plans
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dee60b3051b2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.xz
+*.tgz
+*.gz
+.project
+.settings
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef9f911daa67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Iliya Ivanov <aur@proforge.org>
+
+pkgname=pg_show_plans
+pkgver=1.0.0
+_pkgver=REL_EE_${pkgver//./_}
+
+pkgrel=1
+pkgdesc="Shows the query plans of all currently running SQL statements"
+arch=('x86_64')
+url="https://www.cybertec-postgresql.com/en/products/pg-show-plans/"
+license=('The PostgreSQL Licence')
+depends=('postgresql')
+backup=('')
+source=("https://github.com/cybertec-postgresql/${pkgname}/archive/${_pkgver}.tar.gz")
+sha256sums=('775a0329d92d7a467eba324d89c5629a3dafe887dd4ce1b9fc35b0d2ec396c73')
+
+build() {
+ cd "${srcdir}/${pkgname}-${_pkgver}"
+ export USE_PGXS=1
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${_pkgver}"
+ export USE_PGXS=1
+ export DESTDIR="${pkgdir}"
+ make install
+}