summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJure Kobal2015-06-11 22:32:44 +0200
committerJure Kobal2015-06-11 22:32:44 +0200
commitd27dbd539f3bf71f339a76655c4c6aa173e14486 (patch)
tree200eead32f6132ac0626e92d8f8ccb97ce3ee4cc
downloadaur-d27dbd539f3bf71f339a76655c4c6aa173e14486.tar.gz
Import to aur4.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--pgagent.install9
-rw-r--r--pgagent@.service15
-rw-r--r--pgagent@localhost25
5 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d477ba2cf0e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pgagent
+ pkgdesc = Job scheduler for PostgreSQL
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = http://www.pgadmin.org
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = cmake
+ depends = wxgtk
+ depends = postgresql-libs
+ backup = etc/conf.d/pgagent@localhost
+ source = http://ftp.postgresql.org/pub/pgadmin3/release/pgagent/pgAgent-3.4.0-Source.tar.gz
+ source = pgagent@localhost
+ source = pgagent@.service
+ sha256sums = 0da0ac8f453cf34ab6f708eee036bed0fd0e5fa311de283b92d2ff06600bbb3d
+ sha256sums = 27621bcd7b0f9c5ce5a3680e3df5b7696c3573add25a5ae5730ee6cdbd57e759
+ sha256sums = 4bded1fb970358ff7c98d38b28be1568967f22055bc98cb23f9ae4e3385e3610
+
+pkgname = pgagent
+ install = pgagent.install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5f14b051584
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jure Kobal <j dot kobal at gmx dot com>
+pkgname=pgagent
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="Job scheduler for PostgreSQL"
+url="http://www.pgadmin.org"
+arch=('x86_64' 'i686')
+license=('custom')
+depends=('wxgtk' 'postgresql-libs')
+makedepends=('cmake')
+source=(http://ftp.postgresql.org/pub/pgadmin3/release/pgagent/pgAgent-${pkgver}-Source.tar.gz
+ ${pkgname}@localhost
+ ${pkgname}@.service)
+sha256sums=('0da0ac8f453cf34ab6f708eee036bed0fd0e5fa311de283b92d2ff06600bbb3d'
+ '27621bcd7b0f9c5ce5a3680e3df5b7696c3573add25a5ae5730ee6cdbd57e759'
+ '4bded1fb970358ff7c98d38b28be1568967f22055bc98cb23f9ae4e3385e3610')
+backup=('etc/conf.d/pgagent@localhost')
+
+build() {
+ cd "${srcdir}/pgAgent-${pkgver}-Source"
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DSTATIC_BUILD:BOOL=OFF
+ make
+}
+
+package() {
+ install=pgagent.install
+
+ cd "${srcdir}/pgAgent-${pkgver}-Source"
+ make DESTDIR="${pkgdir}" install
+
+ cd ${srcdir}
+ install -D -m644 ${pkgname}@localhost "${pkgdir}/etc/conf.d/pgagent@localhost"
+ install -D -m644 ${pkgname}@.service "${pkgdir}/usr/lib/systemd/system/${pkgname}@.service"
+}
diff --git a/pgagent.install b/pgagent.install
new file mode 100644
index 000000000000..564dc338d81b
--- /dev/null
+++ b/pgagent.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "To create database environment, load script"
+ echo "/usr/share/pgagent.sql"
+}
+
+post_upgrade() {
+ echo "To update the database environment for the new version,"
+ echo "load the script /usr/share/pgagent_upgrade.sql"
+}
diff --git a/pgagent@.service b/pgagent@.service
new file mode 100644
index 000000000000..78fbfc6b273b
--- /dev/null
+++ b/pgagent@.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Job scheduler for PostgreSQL on %i
+After=network.target
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/conf.d/pgagent@%i
+ExecStart=/usr/bin/pgagent -t ${PGA_POLL} -r ${PGA_RETRY} -s ${PGA_LOG} -l ${PGA_LEVEL} \
+ hostaddr=${PG_HOST} dbname=${PG_DBNAME} user=${PG_USER}
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/pgagent@localhost b/pgagent@localhost
new file mode 100644
index 000000000000..af80d8bf5e1a
--- /dev/null
+++ b/pgagent@localhost
@@ -0,0 +1,25 @@
+# Variables to set the way pgagent works.
+# Commented variables are the defaults that are used in the init-script.
+
+# Pool time interval
+PGA_POLL="10"
+
+# Retry period
+PGA_RETRY="30"
+
+# Log file
+PGA_LOG="/var/log/pgagent.localhost.log"
+
+# Logging verbosity
+# ERROR=0, WARNING=1, DEBUG=2
+PGA_LEVEL="1"
+
+# Server parameters
+# Host address
+PG_HOST="localhost"
+
+# DB name
+PG_DBNAME="postgres"
+
+# Username
+PG_USER="postgres"