summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2019-02-18 01:52:48 +0100
committergéballin2019-02-18 01:52:48 +0100
commit7fa6b09fbed624940199fac26d12ddc171d3ac26 (patch)
treee9381a7e8625dd5367a1fb2187f482725a1ba970
downloadaur-7fa6b09fbed624940199fac26d12ddc171d3ac26.tar.gz
Initial package version for PgBrowse 1.9 .
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42f7200ad7a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pgbrowse
+ pkgdesc = PgBrowse is a graphical PostgreSQL client. It will allow the user to connect to a PostgreSQL database and execute SQL commands (and much more).
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://github.com/Geballin/PgBrowse
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ makedepends = make
+ depends = tcl
+ depends = tk
+ source = https://github.com/Geballin/PgBrowse/archive/1.9.tar.gz
+ md5sums = d0f919afbc838b116927dbe2dce5c4a1
+
+pkgname = pgbrowse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..560cc1a153c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=pgbrowse
+pkgver=1.9
+pkgrel=1
+pkgdesc="PgBrowse is a graphical PostgreSQL client. It will allow the user to connect to a PostgreSQL database and execute SQL commands (and much more)."
+url="https://github.com/Geballin/PgBrowse"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=('tcl' 'tk')
+optdepends=()
+makedepends=(make)
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://github.com/Geballin/PgBrowse/archive/${pkgver}.tar.gz")
+
+md5sums=('d0f919afbc838b116927dbe2dce5c4a1')
+
+build() {
+ cd "${srcdir}/PgBrowse-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ }
+
+package() {
+ cd "${srcdir}/PgBrowse-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ }