summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitri Goutnik2019-02-10 14:24:33 -0500
committerDmitri Goutnik2019-02-10 14:24:33 -0500
commita665c8fbea0d42bf8957d4c98558815c70e5fa2b (patch)
treeacd11a09d51cfda037a306336eaae84adcff4fe1
parent4444dc1f68fbe9982f029757fd8cc04045d91b4b (diff)
downloadaur-a665c8fbea0d42bf8957d4c98558815c70e5fa2b.tar.gz
Updated: pgcenter 0.6.0-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 567c64bbeb74..c889f5c07928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = pgcenter
pkgdesc = Command-line admin tool for observing and troubleshooting Postgres
- pkgver = 0.5.0
- pkgrel = 2
+ pkgver = 0.6.0
+ pkgrel = 1
url = https://github.com/lesovsky/pgcenter
arch = x86_64
license = custom:BSD3
makedepends = go
makedepends = git
- depends = glibc
- source = pgcenter-0.5.0.tar.gz::https://github.com/lesovsky/pgcenter/archive/v0.5.0.tar.gz
- sha256sums = e25e6c7f5f608b89fd6fb68dc24896ab489abbf23e56ec7428867286c469d056
+ source = pgcenter-0.6.0.tar.gz::https://github.com/lesovsky/pgcenter/archive/v0.6.0.tar.gz
+ sha256sums = eb4cb3fda23312ad93f4f59c6f89aa1797d21aa6705812934f3f02e3a762e012
pkgname = pgcenter
diff --git a/PKGBUILD b/PKGBUILD
index efdd14b6238e..7b6992df3273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Maintainer: Dmitri Goutnik <dg@syrec.org>
pkgname=pgcenter
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.6.0
+pkgrel=1
pkgdesc='Command-line admin tool for observing and troubleshooting Postgres'
arch=('x86_64')
url='https://github.com/lesovsky/pgcenter'
license=('custom:BSD3')
-depends=('glibc')
makedepends=('go' 'git')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('e25e6c7f5f608b89fd6fb68dc24896ab489abbf23e56ec7428867286c469d056')
+sha256sums=('eb4cb3fda23312ad93f4f59c6f89aa1797d21aa6705812934f3f02e3a762e012')
prepare() {
- mkdir -p src/github.com/lesovsky
- mv ${pkgname}-${pkgver} src/github.com/lesovsky/pgcenter
- cd src/github.com/lesovsky/pgcenter
- env GOPATH="${srcdir}" GO111MODULE=on go mod download
+ cd ${pkgname}-${pkgver}
+ go mod download
}
build() {
- cd src/github.com/lesovsky/pgcenter
- env GOPATH="${srcdir}" GO111MODULE=on go build -o ${pkgname}
+ cd ${pkgname}-${pkgver}
+ go build -o ${pkgname} \
+ -asmflags all="-trimpath=${PWD}" \
+ -gcflags all="-trimpath=${PWD}" \
+ -ldflags all="-extldflags=${LDFLAGS}"
}
package() {
- cd src/github.com/lesovsky/pgcenter
- install -Dm755 pgcenter "${pkgdir}/usr/bin/${pkgname}"
+ cd ${pkgname}-${pkgver}
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
- env GOPATH="${srcdir}" GO111MODULE=on go clean -modcache
}