summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Jakub Rup2021-03-22 08:43:11 +0100
committerTomasz Jakub Rup2021-03-22 08:43:11 +0100
commit23b23d5ff97235de3055c3f5ca2a44191bcc8356 (patch)
treef332eee72aba39a21cfef8e13145eb9d4c9ab4ee
parentccfced10eaf6de10ea3bd285159dde0af85efa5e (diff)
downloadaur-23b23d5ff97235de3055c3f5ca2a44191bcc8356.tar.gz
new version: 3.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 185044051224..7eaf7394e8b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pgcli
pkgdesc = a command line interface for Postgres with auto-completion and syntax highlighting
- pkgver = 3.0.0
- pkgrel = 2
+ pkgver = 3.1.0
+ pkgrel = 1
url = http://pgcli.com/
arch = any
license = BSD
@@ -19,10 +19,11 @@ pkgbase = pgcli
depends = python-keyring
depends = python-dbus
depends = python-pygments
+ depends = python-pendulum
provides = pgcli
conflicts = pgcli-git
- source = pgcli-3.0.0.zip::https://github.com/dbcli/pgcli/archive/v3.0.0.zip
- md5sums = 86fd20b9ace3091e06607f0ba9aba6f0
+ source = pgcli-3.1.0.zip::https://github.com/dbcli/pgcli/archive/v3.1.0.zip
+ md5sums = 2ce0bab01467c213555756c932b904a5
pkgname = pgcli
diff --git a/PKGBUILD b/PKGBUILD
index 3f4835a165f6..b67b330235bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=pgcli
-pkgver=3.0.0
-pkgrel=2
+pkgver=3.1.0
+pkgrel=1
pkgdesc="a command line interface for Postgres with auto-completion and syntax highlighting"
url="http://pgcli.com/"
arch=(any)
license=('BSD')
-depends=('python' 'python-sqlparse>=0.3.0' 'python-psycopg2' 'python-click>=4.1' 'python-prompt_toolkit' 'python-humanize>=0.5.1' 'python-configobj>=5.0.6' 'python-pgspecial>=1.11.8' 'python-setproctitle>=1.1.9' 'python-cli_helpers>=1.2.0' 'python-keyring' 'python-dbus' 'python-pygments')
+depends=('python' 'python-sqlparse>=0.3.0' 'python-psycopg2' 'python-click>=4.1' 'python-prompt_toolkit' 'python-humanize>=0.5.1' 'python-configobj>=5.0.6' 'python-pgspecial>=1.11.8' 'python-setproctitle>=1.1.9' 'python-cli_helpers>=1.2.0' 'python-keyring' 'python-dbus' 'python-pygments' 'python-pendulum')
makedepends=('python-distribute')
source=($pkgname-$pkgver.zip::https://github.com/dbcli/pgcli/archive/v$pkgver.zip)
provides=('pgcli')
conflicts=('pgcli-git')
-md5sums=('86fd20b9ace3091e06607f0ba9aba6f0')
+md5sums=('2ce0bab01467c213555756c932b904a5')
package() {
cd "$srcdir/pgcli-${pkgver}"
- sed -i -e "s/prompt_toolkit>=2.0.6,<3.0.0/prompt_toolkit>=2.0.6/g" setup.py
- sed -i -e "s/sqlparse >=0.3.0,<0.4/sqlparse >= 0.3.0,<0.5/g" setup.py
+# sed -i -e "s/prompt_toolkit>=2.0.6,<3.0.0/prompt_toolkit>=2.0.6/g" setup.py
+# sed -i -e "s/sqlparse >=0.3.0,<0.4/sqlparse >= 0.3.0,<0.5/g" setup.py
python setup.py install --root="$pkgdir/" --optimize=1
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
cp LICENSE.txt "$_/LICENSE"