summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 11:46:03 +1000
committerPhillip Smith2015-06-02 11:46:03 +1000
commitc21e59a1d4f3037c3435b0a8d6b29c97445b73c6 (patch)
treef2ba8309096f44ff8366e60241027f2d05b42141
downloadaur-c21e59a1d4f3037c3435b0a8d6b29c97445b73c6.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c1d53f690ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pgdbf
+ pkgdesc = Convert XBase databases - particularly FoxPro tables with memo files - into a format that PostgreSQL can directly import
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/kstrauser/pgdbf
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ source = pgdbf-0.6.2.tar.gz::https://github.com/kstrauser/pgdbf/archive/v{0.6.2}.tar.gz
+ md5sums = f9a63ce5e5794b67f20092bf9daf875a
+
+pkgname = pgdbf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a34ee8d9dab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pgdbf-*.pkg.tar.xz
+/pgdbf-*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b1787810dee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=pgdbf
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Convert XBase databases - particularly FoxPro tables with memo files - into a format that PostgreSQL can directly import"
+arch=('i686' 'x86_64')
+license=('GPLv3')
+url="https://github.com/kstrauser/pgdbf"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kstrauser/$pkgname/archive/v{$pkgver}.tar.gz")
+md5sums=('9b42918b9129ff39d737f405e17bd07a')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ autoreconf --install
+
+ # configure
+ ./configure \
+ --prefix=/usr \
+ --enable-installdocs
+
+ # build
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: