summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engeström2015-06-09 01:49:11 +0200
committerEric Engeström2015-06-09 01:49:11 +0200
commit19975355702db2f8917decaa225b71ffeaa981ee (patch)
treee0ed847c2e92a0beef9c7c0518ba4550365d9655
downloadaur-19975355702db2f8917decaa225b71ffeaa981ee.tar.gz
initial commit - v0.7-2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--pgf-umlsd.install14
4 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cbc9e4f38dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pgf-umlsd
+ pkgdesc = Some LaTeX macros for UML Sequence Diagrams
+ pkgver = 0.7
+ pkgrel = 2
+ url = https://code.google.com/p/pgf-umlsd/
+ install = pgf-umlsd.install
+ arch = any
+ license = GPL3
+ depends = texlive-core
+ source = https://pgf-umlsd.googlecode.com/files/pgf-umlsd-0.7.zip
+ md5sums = 9857cef889b662879c2f78516adc0144
+
+pkgname = pgf-umlsd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c4c4ffc6aa41
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d6ca5f43a89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=pgf-umlsd
+pkgver=0.7
+pkgrel=2
+pkgdesc="Some LaTeX macros for UML Sequence Diagrams"
+url="https://code.google.com/p/pgf-umlsd/"
+license=('GPL3')
+arch=('any')
+depends=('texlive-core')
+install=${pkgname}.install
+source=("https://${pkgname}.googlecode.com/files/${pkgname}-${pkgver}.zip")
+md5sums=('9857cef889b662879c2f78516adc0144')
+
+package() {
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/${pkgname}.sty" "${pkgdir}/usr/share/texmf/tex/latex/${pkgname}/${pkgname}.sty"
+}
diff --git a/pgf-umlsd.install b/pgf-umlsd.install
new file mode 100644
index 000000000000..c04e251eea10
--- /dev/null
+++ b/pgf-umlsd.install
@@ -0,0 +1,14 @@
+post_install() {
+ post_remove
+ echo "The file was installed in:"
+ kpsewhich pgf-umlsd.sty
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}