summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0xjac2021-11-01 18:48:17 +0100
committer0xjac2021-11-01 18:48:17 +0100
commit36a4602de54ddc24a82e4b3626ce12d29e9b0ca0 (patch)
tree77baa03ce7d8bfe62e56321f44ada12a64735756
downloadaur-36a4602de54ddc24a82e4b3626ce12d29e9b0ca0.tar.gz
pkg: 2021.09.07-1
initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f490b41fc2b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pggen-bin
+ pkgdesc = Generate type safe Go methods from Postgres SQL queries.
+ pkgver = 2021.09.07
+ pkgrel = 1
+ url = https://github.com/jschaf/pggen
+ arch = x86_64
+ license = MIT
+ provides = pggen
+ conflicts = pggen
+ source_x86_64 = https://github.com/jschaf/pggen/releases/download/2021-09-07/pggen-linux-amd64.zip
+ source_x86_64 = https://raw.githubusercontent.com/jschaf/pggen/2021-09-07/LICENSE
+ sha256sums_x86_64 = 2833a27c33b44fe5806377cf7c1407db6e3f6282baa2c8d7c06577d373c926ee
+ sha256sums_x86_64 = f55840b88fc0081b22cc24ff94fb30a0be81e3998ee05adcffa64f1188958d9d
+
+pkgname = pggen-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5554994c85db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: 0xjac <aur at 0xjac dot com>
+
+pkgname=pggen-bin
+pkgdesc="Generate type safe Go methods from Postgres SQL queries."
+pkgver=2021.09.07
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/jschaf/pggen"
+license=('MIT')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source_x86_64=("https://github.com/jschaf/${pkgname%-bin}/releases/download/${pkgver//./-}/${pkgname%-bin}-linux-amd64.zip"
+ "https://raw.githubusercontent.com/jschaf/${pkgname%-bin}/${pkgver//./-}/LICENSE")
+sha256sums_x86_64=('2833a27c33b44fe5806377cf7c1407db6e3f6282baa2c8d7c06577d373c926ee'
+ 'f55840b88fc0081b22cc24ff94fb30a0be81e3998ee05adcffa64f1188958d9d')
+
+package() {
+ install -Dm755 "${pkgname%-bin}-linux-amd64" "$pkgdir/usr/bin/${pkgname%-bin}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}