summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2018-05-06 09:27:39 +0200
committerGilrain2018-05-06 09:27:39 +0200
commit13ae2e31318667c27050f3ca8770aa10fecd86fc (patch)
tree366ee24ea51b116c753026ebea55ae2c113c7375
parentb681d769662f42c8854c10a456da8abeb8e646a2 (diff)
downloadaur-13ae2e31318667c27050f3ca8770aa10fecd86fc.tar.gz
enable cron support to fix /tmp/execute-all-pgl-commands.sh
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ff65c8f718..56f5de5a4579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Thu Jan 14 14:36:52 UTC 2016
pkgbase = pgl-git
pkgdesc = A privacy oriented firewall application (Daemon, CLI & GUI).
pkgver = 2.3.1.1.r32.g13f606f
@@ -20,6 +18,7 @@ pkgbase = pgl-git
depends = wget
depends = iptables
depends = libnetfilter_queue
+ depends = cron
depends = qt5-base
depends = whois
optdepends = unzip: for zipped blocklists
diff --git a/PKGBUILD b/PKGBUILD
index aa88a6140d78..dd06939a68f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='A privacy oriented firewall application (Daemon, CLI & GUI).'
arch=('i686' 'x86_64')
url='http://sourceforge.net/projects/peerguardian/'
license=('GPL3')
-depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt5-base' 'whois')
+depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'cron' 'qt5-base' 'whois')
optdepends=('unzip: for zipped blocklists'
'p7zip: for 7z blocklists'
'net-tools: to whitelist local IP addresses'
@@ -43,7 +43,7 @@ build() {
cd code
./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --localstatedir=/var --datarootdir=/usr/share \
- --with-piddir=/run --with-systemd --disable-cron --without-initddir
+ --with-piddir=/run --with-systemd --without-initddir
make
}