summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2016-01-14 15:37:47 +0100
committerGilrain2016-01-14 15:37:47 +0100
commitb681d769662f42c8854c10a456da8abeb8e646a2 (patch)
treec30807f417bcc9b80d795c8936c0de3103e227f6
parent7233939a0259395a0ac6b207d6f1546656613598 (diff)
downloadaur-b681d769662f42c8854c10a456da8abeb8e646a2.tar.gz
pglgui has been ported to Qt5.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD38
2 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 922dad077c92..c9ff65c8f718 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Jan 14 14:36:52 UTC 2016
pkgbase = pgl-git
- pkgdesc = A privacy oriented firewall application (Daemon & CLI).
- pkgver = 2.3.0.1.r11.g6cf53bc
+ pkgdesc = A privacy oriented firewall application (Daemon, CLI & GUI).
+ pkgver = 2.3.1.1.r32.g13f606f
pkgrel = 1
url = http://sourceforge.net/projects/peerguardian/
install = install
@@ -18,8 +20,7 @@ pkgbase = pgl-git
depends = wget
depends = iptables
depends = libnetfilter_queue
- depends = qt4
- depends = polkit-qt4
+ depends = qt5-base
depends = whois
optdepends = unzip: for zipped blocklists
optdepends = p7zip: for 7z blocklists
diff --git a/PKGBUILD b/PKGBUILD
index abd79a69e4cf..aa88a6140d78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname=pgl-git
-pkgver=2.3.0.1.r11.g6cf53bc
+pkgver=2.3.1.1.r32.g13f606f
pkgrel=1
-pkgdesc='A privacy oriented firewall application (Daemon & CLI).'
+pkgdesc='A privacy oriented firewall application (Daemon, CLI & GUI).'
arch=('i686' 'x86_64')
url='http://sourceforge.net/projects/peerguardian/'
license=('GPL3')
-depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt4' 'polkit-qt4' 'whois')
+depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt5-base' 'whois')
optdepends=('unzip: for zipped blocklists'
- 'p7zip: for 7z blocklists'
- 'net-tools: to whitelist local IP addresses'
- 'networkmanager: to whitelist newly started network interfaces'
- 'smtp-forwarder: to send reports'
- 'tcptraceroute: to diagnose connection problems')
+ 'p7zip: for 7z blocklists'
+ 'net-tools: to whitelist local IP addresses'
+ 'networkmanager: to whitelist newly started network interfaces'
+ 'smtp-forwarder: to send reports'
+ 'tcptraceroute: to diagnose connection problems')
makedepends=('git' 'zlib')
license=('GPL3')
provides=('pgl')
conflicts=('pgl' 'pgl-cli')
backup=('etc/pgl/allow.p2p'
- 'etc/pgl/blocklists.list'
- 'etc/pgl/pglcmd.conf'
- 'etc/logrotate.d/pglcmd'
- 'etc/logrotate.d/pgld')
+ 'etc/pgl/blocklists.list'
+ 'etc/pgl/pglcmd.conf'
+ 'etc/logrotate.d/pglcmd'
+ 'etc/logrotate.d/pgld')
install=install
source=('git://git.code.sf.net/p/peerguardian/code/')
sha256sums=('SKIP')
pkgver() {
- cd "code"
+ cd code
git describe --tags | sed 's/^debian\///;s/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -40,13 +40,7 @@ prepare() {
}
build() {
- cd "code"
-
- # makes sure qt4 is used
- export QMAKE=qmake-qt4
- export MOC=moc-qt4
- export UIC=uic-qt4
- export RCC=rcc-qt4
+ cd code
./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --localstatedir=/var --datarootdir=/usr/share \
--with-piddir=/run --with-systemd --disable-cron --without-initddir
@@ -54,9 +48,9 @@ build() {
}
package() {
- cd "code"
+ cd code
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir" install
# integrates daemon log in systemd journal
sed -i '/^LOG_SYSLOG/s/0/1/g' $pkgdir/usr/lib/pgl/pglcmd.defaults