summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThore Boedecker2017-05-13 17:10:36 +0200
committerThore Boedecker2017-05-13 17:10:36 +0200
commit116c37f1fb800f62f46f8c1149ae8bb36c865e5d (patch)
tree31c2116d2bb0857bea4c76a6c5e9dbced3e907f0
downloadaur-116c37f1fb800f62f46f8c1149ae8bb36c865e5d.tar.gz
initial version
Signed-off-by: Thore Boedecker <me@foxxx0.de>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9c60db9819d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat May 13 15:10:32 UTC 2017
+pkgbase = pglogical2
+ pkgdesc = Logical replaction for PostgreSQL
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://2ndquadrant.com/en/resources/pglogical/
+ arch = i686
+ arch = x86_64
+ license = custom:PostgreSQL
+ depends = postgresql
+ provides = pglogical=2.0.0
+ source = pglogical-2.0.0.tar.xz::https://github.com/2ndQuadrant/pglogical/archive/REL2_0_0.tar.gz
+ sha512sums = b5651cd402f0c3b453811cbade09d2b3ec1f30b4da05b0282f87481bda3e0618163e539128f8f6755c7eaff669f8f43a9e3e55dfe9323f7579d88e437a60be20
+
+pkgname = pglogical2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c57bbb533e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Thore Bödecker <me [at] foxxx0 [dot] de>
+pkgname=pglogical2
+_pkgbase="${pkgname%2}"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Logical replaction for PostgreSQL"
+arch=('i686' 'x86_64')
+url="https://2ndquadrant.com/en/resources/pglogical/"
+license=('custom:PostgreSQL')
+depends=('postgresql')
+provides=("${_pkgbase}=${pkgver}")
+source=("${_pkgbase}-${pkgver}.tar.xz::https://github.com/2ndQuadrant/${_pkgbase}/archive/REL${pkgver//\./_}.tar.gz")
+sha512sums=('b5651cd402f0c3b453811cbade09d2b3ec1f30b4da05b0282f87481bda3e0618163e539128f8f6755c7eaff669f8f43a9e3e55dfe9323f7579d88e437a60be20')
+
+build() {
+ cd "${srcdir}/${_pkgbase}-REL${pkgver//\./_}"
+ make USE_PGXS=1
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-REL${pkgver//\./_}"
+ make DESTDIR="${pkgdir}" USE_PGXS=1 install
+ install -D -m644 /usr/share/licenses/postgresql/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}