summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen2018-08-22 10:26:46 +0200
committerBen2018-08-22 10:26:46 +0200
commit403163ef82e53bc0982e9fba9a45186680e44bf3 (patch)
tree6d9ba65a53be7e1cef6e63fd1ade528011677103
downloadaur-403163ef82e53bc0982e9fba9a45186680e44bf3.tar.gz
import of PKGBUILD from postage-bin
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD37
-rw-r--r--pgManage.sh3
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55f3efb2e4ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = pgmanage-bin
+ pkgdesc = pgManage - A fast alternative to PGAdmin
+ pkgver = 10.3.1
+ pkgrel = 1
+ url = https://www.workflowproducts.com/services.html#software
+ arch = i686
+ arch = x86_64
+ license = custom:postage,
+ license = custom:electron,
+ license = custom:chromium
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ source = LICENSE.pgManage.txt::https://raw.githubusercontent.com/pgManage/pgManage/master/LICENSE
+ source = pgManage.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+ source_i686 = pgmanage-bin-10.3.1-i686.rpm::https://github.com/pgManage/pgManage/releases/download/v10.3.1/pgManage-10.3.1-ia32.rpm
+ md5sums_i686 = ae51e9e05c1838785ba5a805cb1a2452
+ source_x86_64 = pgmanage-bin-10.3.1-x86_64.rpm::https://github.com/pgManage/pgManage/releases/download/v10.3.1/pgManage-10.3.1.rpm
+ md5sums_x86_64 = b8ecbad69f4c78fa9ed5421335023e70
+
+pkgname = pgmanage-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc2d08ac9364
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Benjamin Schäfer <b-schaefer at posteo dot de>
+# Contributor: Lorenzo Giuliani <lorenzo at giuliani dot me>
+
+pkgname=pgmanage-bin
+pkgver=10.3.1
+pkgrel=1
+pkgdesc="pgManage - A fast alternative to PGAdmin"
+arch=('i686' 'x86_64')
+url="https://www.workflowproducts.com/services.html#software"
+license=('custom:postage', 'custom:electron', 'custom:chromium')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss')
+makedepends=('')
+name=pgManage
+source=("LICENSE.${name}.txt::https://raw.githubusercontent.com/${name}/${name}/master/LICENSE"
+ "${name}.sh")
+source_i686=("${pkgname}-${pkgver}-i686.rpm::https://github.com/${name}/${name}/releases/download/v${pkgver}/${name}-${pkgver}-ia32.rpm")
+source_x86_64=("${pkgname}-${pkgver}-x86_64.rpm::https://github.com/${name}/${name}/releases/download/v${pkgver}/${name}-${pkgver}.rpm")
+sha256sums=('SKIP' 'SKIP')
+md5sums_i686=('ae51e9e05c1838785ba5a805cb1a2452')
+md5sums_x86_64=('b8ecbad69f4c78fa9ed5421335023e70')
+
+package() {
+ install -d "${pkgdir}"/opt/${name}
+ install -d "${pkgdir}"/usr/bin
+ install -d "${pkgdir}"/usr/share/applications
+ install -d "${pkgdir}"/usr/share/icons
+
+ cp --preserve=mode -r "${srcdir}"/opt/${name}/* "${pkgdir}"/opt/${name}
+ cp --preserve=mode -r "${srcdir}"/usr/share/applications/* "${pkgdir}"/usr/share/applications
+ cp --preserve=mode -r "${srcdir}"/usr/share/icons/* "${pkgdir}"/usr/share/icons
+
+ install -Dm644 "${srcdir}"/opt/${name}/LICENSES.chromium.html "${pkgdir}"/usr/share/licenses/${name}/LICENSES.chromium.html
+ install -Dm644 "${srcdir}"/opt/${name}/LICENSE.electron.txt "${pkgdir}"/usr/share/licenses/${name}/LICENSE.electron.txt
+ install -Dm644 "${srcdir}"/LICENSE.${name}.txt "${pkgdir}"/usr/share/licenses/${name}/LICENSE.${name}.txt
+ install -m755 ${name}.sh "${pkgdir}"/usr/bin/${name}
+}
+
diff --git a/pgManage.sh b/pgManage.sh
new file mode 100644
index 000000000000..54c93aa47e80
--- /dev/null
+++ b/pgManage.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /opt/pgManage/pgmanage