summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Düll2015-07-04 14:02:10 +0200
committerMichael Düll2015-07-04 14:02:10 +0200
commit0f7ffffbc9b9fb8b18a8fad6c96031b0cf0bc23b (patch)
tree74b09413275ee0fe199815c9fbc01690bf188670
downloadaur-0f7ffffbc9b9fb8b18a8fad6c96031b0cf0bc23b.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..650db0450d6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pgpdump-git
+ pkgdesc = Dumps information (Used Keys, moduli, r, s, ...) from a OpenPGP compatible file.
+ pkgver = v0.28.r14.ga65eb20
+ pkgrel = 2
+ epoch = 1
+ url = http://www.mew.org/~kazu/proj/pgpdump/en/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = bzip2
+ depends = zlib
+ provides = pgpdump
+ conflicts = pgpdump
+ source = pgpdump::git+https://github.com/kazu-yamamoto/pgpdump.git
+ sha384sums = SKIP
+
+pkgname = pgpdump-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36968f0badaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Duell <michael.duell@rub.de> PGP-Fingerprint: FF8C D50E 66E9 5491 F30C B75E F32C 939C 5566 FF77
+# Contributor: s1gma <s1gma@mindslicer.com>
+
+pkgname=pgpdump-git
+pkgver=v0.28.r14.ga65eb20
+epoch=1
+pkgrel=2
+pkgdesc="Dumps information (Used Keys, moduli, r, s, ...) from a OpenPGP compatible file."
+arch=('i686' 'x86_64')
+url="http://www.mew.org/~kazu/proj/pgpdump/en/"
+license=('BSD')
+depends=('bzip2' 'zlib')
+makedepends=('git')
+provides=('pgpdump')
+conflicts=('pgpdump')
+source=('pgpdump::git+https://github.com/kazu-yamamoto/pgpdump.git')
+sha384sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/pgpdump
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir"/pgpdump
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/pgpdump
+ make DESTDIR="$pkgdir" install
+}