summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2020-07-03 01:12:16 +0200
committerPellegrino Prevete2020-07-03 01:12:16 +0200
commitf83e68aef7baaa1369a34cbe6a2f05a94ddc7b41 (patch)
treee3db774189418abb729af21d0b7f8f7ff8131901
downloadaur-f83e68aef7baaa1369a34cbe6a2f05a94ddc7b41.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..826f0d33f5e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pgpgram
+ pkgdesc = PGP encrypted backups on Telegram Cloud
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/tallero/pgpgram
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-setproctitle
+ depends = telegram-tdlib
+ source = pgpgram::git+https://github.com/tallero/pgpgram.git
+ sha256sums = SKIP
+
+pkgname = pgpgram
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d902d9fe1db1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Mantainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+
+pkgname=pgpgram
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='PGP encrypted backups on Telegram Cloud'
+arch=('any')
+url='https://github.com/tallero/pgpgram'
+license=('GPL')
+depends=('python' 'python-setproctitle' 'telegram-tdlib')
+makedepends=('python-setuptools')
+source=('pgpgram::git+https://github.com/tallero/pgpgram.git')
+sha256sums=('SKIP')
+
+package() {
+ cd "${pkgname}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim: ts=2 sw=2 et: