summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroFloyd2015-07-27 19:13:42 +0200
committerAstroFloyd2015-07-27 19:13:42 +0200
commitd16269a1f0ab13b9038d785e35b4d401adc3b286 (patch)
tree3e07ef6e86218956ac83813394734363c6c934db
downloadaur-d16269a1f0ab13b9038d785e35b4d401adc3b286.tar.gz
Initial commit: v5.2.2-6, created by jmorin on 2012-09-20
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--pndriv.c.patch11
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af1c935f8cf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pgplot
+ pkgdesc = Fortran- or C-callable, device-independent graphics package for making simple scientific graphs.
+ pkgver = 5.2.2
+ pkgrel = 6
+ url = http://www.astro.caltech.edu/~tjp/pgplot/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc-fortran
+ depends = libpng
+ depends = libx11
+ options = !makeflags
+ source = ftp://ftp.astro.caltech.edu/pub/pgplot/pgplot522.tar.gz
+ source = pndriv.c.patch
+ md5sums = e8a6e8d0d5ef9d1709dfb567724525ae
+ md5sums = 25535f059b2e39ea44f93c24a41abacd
+
+pkgname = pgplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4623152b202c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Julien Morin <morin.jul@gmail.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=pgplot
+pkgver=5.2.2
+pkgrel=6
+pkgdesc="Fortran- or C-callable, device-independent graphics package for making simple scientific graphs."
+url="http://www.astro.caltech.edu/~tjp/pgplot/"
+license=('custom')
+options=(!makeflags)
+arch=('i686' 'x86_64')
+makedepends=('gcc-fortran')
+depends=('libpng' 'libx11')
+source=(ftp://ftp.astro.caltech.edu/pub/pgplot/${pkgname}522.tar.gz pndriv.c.patch)
+md5sums=('e8a6e8d0d5ef9d1709dfb567724525ae' '25535f059b2e39ea44f93c24a41abacd')
+
+build() {
+ cd $srcdir/$pkgname
+ sed -i 's/! CGDRIV/CGDRIV/' drivers.list
+ sed -i 's/! LXDRIV/LXDRIV/' drivers.list
+ #sed -i 's/! PNDRIV/PNDRIV/' drivers.list
+ sed -i 's/! PSDRIV/PSDRIV/' drivers.list
+ sed -i 's/! TTDRIV 5/TTDRIV 5/' drivers.list
+ sed -i 's/! XWDRIV/XWDRIV/1' drivers.list
+ patch -p0 -i "${srcdir}"/pndriv.c.patch
+
+ ./makemake . linux g77_gcc
+ sed -i 's=pndriv.o : ./png.h ./pngconf.h ./zlib.h ./zconf.h=#pndriv.o : ./png.h ./pngconf.h ./zlib.h ./zconf.h=' makefile
+ make FCOMPL=gfortran SHARED_LIB_LIBS="-lpng -lz" all cpg || return 1
+
+ install -D -m644 libpgplot.a $pkgdir/usr/lib/libpgplot.a
+ install -D -m755 libpgplot.so $pkgdir/usr/lib/libpgplot.so
+ install -D -m644 grfont.dat $pkgdir/usr/lib/grfont.dat
+ install -D -m644 rgb.txt $pkgdir/usr/lib/rgb.txt
+ install -D -m755 pgxwin_server $pkgdir/usr/bin/pgxwin_server
+ install -D -m644 libcpgplot.a $pkgdir/usr/lib/libcpgplot.a
+ install -D -m644 cpgplot.h $pkgdir/usr/include/cpgplot.h
+ install -D -m644 copyright.notice $pkgdir/usr/share/licenses/custom/$pkgname/copyright.notice
+}
diff --git a/pndriv.c.patch b/pndriv.c.patch
new file mode 100644
index 000000000000..4d8a22d3ee70
--- /dev/null
+++ b/pndriv.c.patch
@@ -0,0 +1,11 @@
+-- drivers/pndriv.c 2012-02-05 18:35:41.172818257 +0100
++++ drivers/pndriv.c 2012-02-05 18:36:34.389199228 +0100
+@@ -222,7 +222,7 @@
+ return;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) { /* not really sure what I'm doing here... */
++ if (setjmp(png_jmpbuf(png_ptr))) {/* not really sure what I'm doing here... */
+ fprintf(stderr,"%s: error in libpng while writing file %s, plotting disabled\n", png_ident, filename);
+ png_destroy_write_struct(&png_ptr,&info_ptr);
+ dev->error = true;