summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaudouin Feildel2018-10-06 12:18:03 +0200
committerBaudouin Feildel2018-10-06 12:19:27 +0200
commit052b547578bdd304172d5d1395ea1f2ae7592574 (patch)
treee6ec67cb93f474e7131089edf97f8303d7ff5f4c
downloadaur-052b547578bdd304172d5d1395ea1f2ae7592574.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--pgpointcloud.changelog81
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8beb78aae1b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pgpointcloud
+ pkgdesc = A PostgreSQL extension for storing point cloud (LIDAR) data
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/pgpointcloud/pointcloud
+ changelog = pgpointcloud.changelog
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cunit
+ makedepends = laz-perf
+ depends = libxml2
+ optdepends = laz-perf: LAZ compression support
+ provides = pgpointcloud=1.2.0
+ conflicts = pgpointcloud-git
+ source = https://github.com/pgpointcloud/pointcloud/archive/v1.2.0.tar.gz
+ sha256sums = 8542a4c714b4d0c67f10d092291a43b5650871b4ec8caf831e492810f25bb93c
+
+pkgname = pgpointcloud
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49effe408769
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Baudouin Feildel <baudouin_aur@feildel.fr>
+pkgname=pgpointcloud
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A PostgreSQL extension for storing point cloud (LIDAR) data"
+arch=('i686' 'x86_64')
+url="https://github.com/pgpointcloud/pointcloud"
+license=('BSD')
+depends=('libxml2')
+optdepends=('laz-perf: LAZ compression support')
+makedepends=('cunit' 'laz-perf')
+provides=("pgpointcloud=$pkgver")
+conflicts=('pgpointcloud-git')
+changelog="$pkgname.changelog"
+source=("https://github.com/pgpointcloud/pointcloud/archive/v$pkgver.tar.gz")
+sha256sums=('8542a4c714b4d0c67f10d092291a43b5650871b4ec8caf831e492810f25bb93c')
+
+build() {
+ cd "${pkgname#pg}-$pkgver"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${pkgname#pg}-$pkgver"
+
+ make check
+}
+
+package() {
+ cd "${pkgname#pg}-$pkgver"
+
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/pgpointcloud.changelog b/pgpointcloud.changelog
new file mode 100644
index 000000000000..09693bedf7aa
--- /dev/null
+++ b/pgpointcloud.changelog
@@ -0,0 +1,81 @@
+1.2.0, 2018-08-22
+-----------------
+
+- New features
+ - Add PC_MakePatch(pcid integer, values float8[]) #220
+ - Mark functions as PARALLEL SAFE #227
+
+- Bug fixes
+ - patch fails to compress as GHT #35
+ - libght breaks schema parsing #196
+ - Fix memcpy size in pc_patch_wkb_set_int32 #226
+
+- Enhancements
+ - Improve doc for PC_FilterBetween #217
+ - Remove GHT support #214
+ - Fix installcheck when lazperf is disabled #222
+ - Fix compilation and installcheck when lazperf is disabled #224
+
+1.1.1, 2018-06-12
+-----------------
+
+- Bug fixes
+ - Fix bug in pc_patch_uncompressed_from_lazperf (#215)
+
+- Enhancements
+ - Document creating a PC_EnvelopeGeometry-based index (#208)
+ - Use PostgreSQL 9.6 with PostGIS 2.4 on Travis (#210)
+ - Add missing description in AC_DEFINE (#213)
+
+1.1.0, 2018-04-30
+-----------------
+
+- New functions
+ - PC_PCId(pcpoint|pcpatch)
+ - PC_Get(pcpoint) returns float8[]
+ - PC_Summary(pcpatch)
+ - PC_Patch{Min,Max,Avg}(pcpatch) returns pcpoint (#77)
+ - PC_Upgrade([<target_version>])
+ - PC_Lib_Version(), PC_Script_Version() (#40)
+ - PC_Sort(pcpatch,text[]) (#106)
+ - PC_IsSorted(pcpatch,text[],boolean) (#106)
+ - PC_Range(pcpatch, int, int) returns pcpatch (#152)
+ - PC_BoundingDiagonalAsBinary(pcpatch) and PC_BoundingDiagonalGeometry(pcpach) (#158)
+ - PC_SetPCId(pcpatch, int, float8 default 0.0) (#163)
+ - PC_Transform(pcpatch, int, float8 default 0.0) (#165)
+ - PC_Full_Version() (#201)
+
+- Enhancements
+ - Support sigbits encoding for 64bit integers (#61)
+ - Warn about truncated values (#68)
+ - Warn about script/lib version mismatch (#40)
+ - Compatibility with PostgreSQL 9.5 (#90)
+ - Support LAZ compression for PcPatch (#105)
+
+1.0.1, 2015-08-09
+-----------------
+
+- Bug fixes
+ - #79, Fix PC_Filter stats computation with dimensionally-compressed
+ patches
+ - #78, Fix PC_Filter stats computation with scaled dimensions
+ - #71, Fix crash in pc_schema_from_xml
+ - #66, Fix crash in pc_schema_clone (unexploitable via SQL)
+ - #37, Fix access to uninitialized variables
+ - #31, Fix crash in pc_patch
+ - #28, Fix uninterruptible loop from pc_schemaisvalid
+ - #27, Fix pointcloud_columns view definition to handle
+ null-typmoded cols
+ - #23, Fix computation of dimensional patch extent
+ - #26, Fix cmake build with GCC 4.8 (-fPIC)
+
+- Enhancements
+ - #39, Provide upgrade scripts
+
+1.0.0
+-----
+
+Initial release, also known as:
+ - 0.1.0 (git tag v0.1.0)
+ - 1.0 (extension script filename)
+