summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlottiere Paul2023-09-19 20:58:32 +0200
committerBlottiere Paul2023-09-19 20:58:32 +0200
commitfca303a285162f7ad57b9001c678e0522560f912 (patch)
tree196e7be0fd2f6bddd07a9c5b6f8bcaa690e7a48a
parent84e69e29a73b58402e13d8fbb81b623b86a83582 (diff)
downloadaur-fca303a285162f7ad57b9001c678e0522560f912.tar.gz
v1.2.5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD17
-rw-r--r--pgpointcloud.changelog62
-rw-r--r--pointcloud-1.2.0-fix-compilation-against-pg11.patch54
4 files changed, 72 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6cc710222c7..0287655b746f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = pgpointcloud
pkgdesc = A PostgreSQL extension for storing point cloud (LIDAR) data
- pkgver = 1.2.0
- pkgrel = 4
+ pkgver = 1.2.5
+ pkgrel = 1
url = https://github.com/pgpointcloud/pointcloud
changelog = pgpointcloud.changelog
arch = i686
arch = x86_64
- license = BSD
+ license = custom: pgpointcloud
makedepends = cunit
- makedepends = laz-perf
+ makedepends = clang15
+ makedepends = llvm15
depends = libxml2
- optdepends = laz-perf: LAZ compression support
- provides = pgpointcloud=1.2.0
+ provides = pgpointcloud=1.2.5
conflicts = pgpointcloud-git
- source = https://github.com/pgpointcloud/pointcloud/archive/v1.2.0.tar.gz
- source = pointcloud-1.2.0-fix-compilation-against-pg11.patch
- sha256sums = 8542a4c714b4d0c67f10d092291a43b5650871b4ec8caf831e492810f25bb93c
- sha256sums = aa6b1c74aa88e7ec70b78bcb1125a6458ab99261f0debc385ddf6616fe8f628e
+ source = https://github.com/pgpointcloud/pointcloud/archive/v1.2.5.tar.gz
+ sha256sums = f3924f283345f2da46a971e65f0c6ce602640ecf88a2057293443ec2a7a56774
pkgname = pgpointcloud
-
diff --git a/PKGBUILD b/PKGBUILD
index f10fe7ffc2c1..72eae9a474ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Baudouin Feildel <baudouin_aur@feildel.fr>
pkgname=pgpointcloud
-pkgver=1.2.0
-pkgrel=4
+pkgver=1.2.5
+pkgrel=1
pkgdesc="A PostgreSQL extension for storing point cloud (LIDAR) data"
arch=('i686' 'x86_64')
url="https://github.com/pgpointcloud/pointcloud"
-license=('BSD')
+license=('custom: pgpointcloud')
depends=('libxml2')
-optdepends=('laz-perf: LAZ compression support')
-makedepends=('cunit' 'laz-perf')
+optdepends=()
+makedepends=('cunit' 'clang15' 'llvm15')
provides=("pgpointcloud=$pkgver")
conflicts=('pgpointcloud-git')
changelog="$pkgname.changelog"
source=(
"https://github.com/pgpointcloud/pointcloud/archive/v$pkgver.tar.gz"
- "${pkgname#pg}-$pkgver-fix-compilation-against-pg11.patch")
+)
sha256sums=(
- '8542a4c714b4d0c67f10d092291a43b5650871b4ec8caf831e492810f25bb93c'
- 'aa6b1c74aa88e7ec70b78bcb1125a6458ab99261f0debc385ddf6616fe8f628e')
+ 'f3924f283345f2da46a971e65f0c6ce602640ecf88a2057293443ec2a7a56774'
+)
prepare() {
cd "${pkgname#pg}-$pkgver"
- patch -p1 -i "$srcdir/${pkgname#pg}-$pkgver-fix-compilation-against-pg11.patch"
}
build() {
diff --git a/pgpointcloud.changelog b/pgpointcloud.changelog
index fbd5a5335147..578130acab49 100644
--- a/pgpointcloud.changelog
+++ b/pgpointcloud.changelog
@@ -1,10 +1,60 @@
-1.2.0-4, 2019-11-26
--------------------
-PostgreSQL 12 rebuild
+1.2.5, 2023-09-19
+-----------------
+
+- Bug fixes
+ - Fix compilation with PostgreSQL 16 (#340)
+
+1.2.4, 2022-09-26
+-----------------
+
+- Bug fixes
+ - Add upgrade paths for pointcloud_postgis (#327)
-1.2.0-2, 2018-11-26
--------------------
-PostgreSQL 11 rebuild
+- Enhancements
+ - Add support for PostgreSQL 15 (#318)
+
+1.2.3, 2022-09-12
+-----------------
+
+- Bug fixes
+ - Fix segmentation fault in pcpatch_transform (#322)
+ - Fixes uninitialised schema cache during first call (#317)
+ - Don't call SPI_finish() when erroring out (#312)
+ - No crash when an invalid dimensional patch is compressed (#320)
+
+- Enhancements
+ - Add documentation for debugging with Valgrind (#316)
+ - Add documentation for debugging with GDB (#321)
+
+1.2.2, 2022-05-10
+-----------------
+
+- Breaking changes
+ - Drop support for PG 9.6
+
+- Bug fixes
+ - Fix dump and restore #301 #306
+ - Fix compilation with GCC 10.1 #273
+ - Fix compilation with PostgreSQL 13 beta 1 #270
+ - Fix Debian regression tests on 32-bits architecture #260
+ - Fix CXXFLAGS #257
+
+- Enhancements
+ - Add documentation for NESTED_QSORT #293
+ - Add tutorial for schema and compression #299
+ - Add Dockerfile with PostgreSQL 12 and PostGIS 3 #265
+
+1.2.1, 2020-01-01
+-----------------
+
+- Bug fixes
+ - Fix compilation with PostgreSQL 11 #237
+ - Fix compilation with PostgreSQL 12 #243
+
+- Enhancements
+ - Improve documentation for PC_MemSize #232
+ - Fix unit tests with PostgreSQL >= 10 #253
+ - Fix typo in README #238
1.2.0, 2018-08-22
-----------------
diff --git a/pointcloud-1.2.0-fix-compilation-against-pg11.patch b/pointcloud-1.2.0-fix-compilation-against-pg11.patch
deleted file mode 100644
index 38985d4c7cec..000000000000
--- a/pointcloud-1.2.0-fix-compilation-against-pg11.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 3e64c68dd4e0b9b9fdf0a74492ab49023161f6f1 Mon Sep 17 00:00:00 2001
-From: Baudouin Feildel <baudouin@feildel.fr>
-Date: Tue, 27 Nov 2018 00:14:13 +0100
-Subject: [PATCH] Fix boolean case errors when compiling againt pg11
-
----
- pgsql/pc_access.c | 8 ++++----
- pgsql/pc_inout.c | 2 +-
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/pgsql/pc_access.c b/pgsql/pc_access.c
-index 62599f2..3b29201 100644
---- a/pgsql/pc_access.c
-+++ b/pgsql/pc_access.c
-@@ -879,9 +879,9 @@ Datum pcpatch_intersects(PG_FUNCTION_ARGS)
-
- if ( pc_bounds_intersects(&(serpa1->bounds), &(serpa2->bounds)) )
- {
-- PG_RETURN_BOOL(TRUE);
-+ PG_RETURN_BOOL(true);
- }
-- PG_RETURN_BOOL(FALSE);
-+ PG_RETURN_BOOL(false);
- }
-
- PG_FUNCTION_INFO_V1(pcpatch_size);
-@@ -939,9 +939,9 @@ PG_FUNCTION_INFO_V1(pc_lazperf_enabled);
- Datum pc_lazperf_enabled(PG_FUNCTION_ARGS)
- {
- #ifdef HAVE_LAZPERF
-- PG_RETURN_BOOL(TRUE);
-+ PG_RETURN_BOOL(true);
- #else
-- PG_RETURN_BOOL(FALSE);
-+ PG_RETURN_BOOL(false);
- #endif
- }
-
-diff --git a/pgsql/pc_inout.c b/pgsql/pc_inout.c
-index 1378a80..05223f1 100644
---- a/pgsql/pc_inout.c
-+++ b/pgsql/pc_inout.c
-@@ -171,7 +171,7 @@ Datum pcschema_is_valid(PG_FUNCTION_ARGS)
-
- if ( !schema )
- {
-- PG_RETURN_BOOL(FALSE);
-+ PG_RETURN_BOOL(false);
- }
-
- valid = pc_schema_is_valid(schema);
---
-2.19.2
-